Unable to Save after recent upgrade

Upgraded to 3.03 on Windows 11. I own a license and have used the product for over a year. Upon install I was given the option to see what a light screen would look like so I tried it. Now I have no way to export images, change the screen back and it shows as "Trial Mode with no means to change back. Links to “Support” and “Report a problem” do not connect. Two logs attached as well as screenshot. [Please describe your issue here. Try to include logs (Help → Logging) and add screenshots if necessary.]

Steps to reproduce issue:


2024-06-02-16-33-32.tzlog (24.9 KB)
2024-06-05-07-59-19-1.tzlog (1.7 KB)


Topaz Photo AI [v1.x.x] on [Windows/Mac]

Have you recently been able to log into your account in a web browser with the email address associated with your Topaz Labs account?

If so then Topaz Photo AI should also connect to your account. If it does not please make sure you do not have any VPN, proxy servers or anti-virus software running that can cause connection issues for the apps to reach our servers.

You can also clear your cookies and cache in the web browser you use and then log back in before clicking the activate option in the app.

Have tried your suggestions. Logging in to my account brings me to my dashboard but the app still only loads the trial mode. When I click on the “Activate” button it recognizes me and says that I am successfully logged in but then goes back to the same window and trial mode.

Are you using any VPN, proxy, firewall, or antivirus softwares?

VPN and Proxy - No
Firewall through Norton 360 but no changes.
The issue started with the upgrade and my opting into a screen color change offered.

Could you try safe listing the following domains to your Norton 360 as this is where our authentication occurs and it could be blocked by your firewall:

http://api.topaz-labs.net/.
topazlabs.com/.
downloads.topazlabs.com/.
veai-models.topazlabs.com/.
models.topazlabs.com/.
http://et.topazlabs.com/.

Firewall is allowing that traffic.