Unable to edit an image directly from Apple Photos since upgrade to 1.2.9

I mainly use Topaz Photo AI as a “plugin” to Apple Photos, i.e. when editing in Apple Photos, I click on the “three dots” icon and select “Edit in Topaz Photo AI”.

When I had Topaz Photo AI 1.2.7 installed, my photo was then opened in Topaz, as expected.
After upgrading to 1.2.9, nothing happens. I have disabled and re-enabled Topaz Photo AI in the Apple Photos “extensions/plugins” settings, I have rebooted the computer, I’ve tried having Topaz already opened in the background or not, but nothing has helped.

Steps to reproduce issue:

  1. Select an image in Apple Photos
  2. Starting editing it (in Apple Photos)
  3. Click the “extensions” icon, click “Edit in Topaz Photo AI”
    Nothing happens.

The first and second log files I’ve attached are from Topaz Photo AI 1.2.7, when it worked. The third and forth are after the upgrade to 1.2.9.

I had to zip the System Report.

MacBook Pro - lenborje.spx.zip (432.0 KB)

Topaz Photo AI [v1.x.x] on [Windows/Mac]
2023-04-02-08-59-51.tzlog (264.1 KB)
2023-04-02-09-13-21.tzlog (9.6 KB)
2023-04-02-09-08-56.tzlog (9.2 KB)
2023-04-02-09-07-7.tzlog (9.7 KB)

Downgrading to 1.2.7 resolved the problem, i.e. I can once again edit from Apple Photos.

1.2.10 has resolved the problem!

Thank you for letting us know :slight_smile: please reply here if you encounter this behavior again!