TVAI v3.1.0 "add noise" slider no longer seems to do anything

Hello.

When playing with the “add noise” slider, I’m no longer seeing any difference in the output. It seems like it’s just no longer doing anything, like it’s always set to zero under the hood. The output file sizes produced are the same whether or not I set noise to min or max, and I see no difference with my eyes.

I believe this is a new issue with v3.1.0, because I remember noise working a few weeks ago.

I’m using the Artemis model. I’m not sure if this issue applies to other models.

I checked the ffmpeg commands, and I see that the “prenoise” option is being set correctly. Below are snippets from two commands. The first has no noise. The second has a noise setting of “10”, and they are both producing the same output:

“tvai_up=model=ahq-12:scale=0:w=1280:h=720:grain=0.01:gsize=1:device=0:vram=0.9:instances=1,scale=w=1280:h=720:flags=lanczos:threads=0:force_original_aspect_ratio=decrease,pad=1280:720:-1:-1:color=black,split=2[out1][out2]”

“tvai_up=model=ahq-12:scale=0:w=1280:h=720:prenoise=0.1:grain=0.01:gsize=1:device=0:vram=0.9:instances=1,scale=w=1280:h=720:flags=lanczos:threads=0:force_original_aspect_ratio=decrease,pad=1280:720:-1:-1:color=black,split=2[out1][out2]”

I’ll do some more testing with other models and parameters to see if I can learn anything else.

Thanks.

A bit more info…

This problem only seems to apply to exports. Previews do not seem to have this problem. I can see a difference in previews when changing the noise setting, but exports look exactly the same and have the same file size regardless of the noise slider.