TVAI 4.2.0 Stable - AION model "error": conversion don't start!

It’s still running out of memory, looks like your memory limit has been set back to 100%.

You have not understood the situation well:

this NEW error is not related to my “work PC” where I mount an RTX 3070 with 8GB of VRAM (and in that case I solved it by limiting the memory usage to 80%)… but this new error appeared to me with my gaming PC which is completely different, in fact it mounts a RTX 4070 Ti SUPER with as much as 16GB of GDDDR6X VRAM with 256-bit Memory Interface Width (the same used on the RTX 4080)… so I would say that it is therefore IMPOSSIBLE that it is a problem of lack of VRAM!

:melting_face:
What is the source of the problem this time?
You clearly need to fix an underlying problem with this new AI engine!

Can we try with an 80% limit set?

Tried it now–SAME PROBLEM/error!

JakSpoon 4070TiSUPER 80 memory - logsForSupport.zip (702.6 KB)

ffmpeg "-hide_banner" "-i" "C:/Users/Jacopo/Videos/DRAGON BALL Sparking! ZERO  Gameplay Showcase ENG.mp4" "-sws_flags" "spline+accurate_rnd+full_chroma_int" "-color_trc" "1" "-colorspace" "1" "-color_primaries" "1" "-filter_complex" "tvai_fi=model=aion-1:slowmo=4:rdt=0.01:device=0:vram=0.8:instances=1,scale=out_color_matrix=bt709" "-c:v" "hevc_nvenc" "-profile:v" "main" "-pix_fmt" "yuv420p" "-b_ref_mode" "disabled" "-tag:v" "hvc1" "-g" "30" "-preset" "p7" "-tune" "hq" "-rc" "constqp" "-qp" "17" "-rc-lookahead" "20" "-spatial_aq" "1" "-aq-strength" "15" "-b:v" "0" "-map" "0:a" "-map_metadata:s:a:0" "0:s:a:0" "-c:a" "aac" "-ac" "2" "-b:a" "192k" "-map_metadata" "0" "-map_metadata:s:v" "0:s:v" "-movflags" "use_metadata_tags+write_colr" "-metadata" "videoai=Slowmo 400% using aion-1 replacing duplicate frames" "D:\VIDEO\TVAI Stable/DRAGON BALL Sparking! ZERO  Gameplay Showcase ENG_1_aion1.mp4"

Just tested this out and was able to export a portion of this video out with those settings without an issue. I did not run the entire 12 minute long clip.

CPU: i7-8700K 3.70 GHz
GPU: Nvidia RTX 3060 12GB VRAM - Studio Driver 15.4601
RAM: 64 GB
SO: Win 10 home - 19045.4046

If you see in the post above… I shared the screen of the program after the error: the failed video conversion is referring to only a portion of the video (it’s not the full 12 minutes, but only about 4 minutes)… and I have this problem, I repeat, with a high-end GPU and with 16 GB of GDDR6X RAM (even setting the program to use 80 percent video memory)… I would say there is a BIG problem underlying this frame interpolation model!

:expressionless:

Just as some additional input, I happened to do some upgrades to my cooling so I could add more RAM, and it seems like after I tried Aion with 64GB system ram (16GB VRAM), I can use Aion without problems. I see that JakSpoon lists his system RAM at 32GB.

In fact, good Tony was talking about a “memory” problem… but it seems really strange to me that it’s a problem of little RAM installed on the PC:

TVAI uses very little RAM even with the heaviest tasks… and I don’t see this as the case with a PC with “little RAM”… 32GB is the medium-to-high “standard”… expecting to be able to encode a video in AION just by having 64GB of RAM seems to me a really excessive requirement for the vast majority of people!

As user @Imo said, the problem is not the amount of RAM at all: according to him, he has 32GB of RAM and had no problems using the AION model!

Let’s compare the Windows info. I set the swap file to the same size as the RAM (32 GB). Fully disabeling the swap file might cause servere issues on some games and applications.
DxDiag.txt (130.4 KB)

I have same problem.
Aion model stops working.
It works only when used without any other model (like proteus and etc).
And another requirement is that fps change should be > 2x.
For example when 24000/1001 fps converted to 60 fps - it works.
But when 24000/1001 fps without change (with duplicates replace enabled) - it fails.
Also if convert to 30000/1001 fps it fails.

And looks like it is realy a memory problem. I have 8GB vram (nvidia 4060ti).
When memory limit is set to 80% then it fails even with 23.976>60fps conversion.

1 Like

@tony.topazlabs @Imo @kyle.topazlabs

I continued testing with AION, in combination with the latest stable version 4.2.2… and although I have generally noticed improvements, the “problem” I am experiencing is still there, and I may have figured out what it may be due to:

I tried another video, this time I used this one (downloaded in both 1080p AVC 60fps MP4 and 4K VP9 60fps MKV, both not in HDR version, using the 4K Video Downloader+ program):

In doing various tests, I discovered two things:

  1. With my RTX 4070 Ti SUPER 16GB of VRAM, the problem obviously cannot be insufficient video memory: in fact, encoding the video in 1080p with AION 6x, Windows marks me that the program uses about 6GB of VRAM, while in 4K it goes up to 9GB).
  2. The problem occurs (it seems) ONLY when I select a part of the video to be encoded (with the “mark in” and “mark out”), while it seems not to occur when I encode the whole video file: I’ll tell you more… now selecting the part to be converted, when it goes into error, and I re-start the ecoding with the “resolve error” button, it restarts the conversion but this time it converts the ENTIRE video: in fact the encoded video is the total starting video, not the part I selected.

At this point it seems confirmed that it is a BUG of the program coupled with the AI model when choosing to convert only a part of the video!
:melting_face:
I ask you to fix this issue as soon as possible!

JakSpoon AION problem TVAI 422 - logsForSupport.zip (442.8 KB)

JakSppon - DxDiag v2.txt (104.1 KB)

1 Like

I have run some tests with mp4 files, and I am continuing to do so with other files that I am setting an In/Out marker and exporting using Aion and so far, they have all worked. Going to convert a few files into mkv as well and I will get back to you on if I run into the same issue.
DxDiag 4-2-24.txt (115.1 KB)

1 Like

Just wanted the add that I am having the same issue. I cannot preview or export any video using AION Frame Intropolation without getting an out of memory error in the current release or the beta version soon to be released. I am on a M1 Max 64GB Sonoma 14.4.1

1 Like