TPAI still has problems with saving back edited photos to Apple Photos

See the title.

Steps to reproduce issue:

  1. Step 1
    Open Apple Photos, select edit on a photo and then Edit in Topaz Photo AI
  2. Step 2
    Edit the image in TPAI
  3. Step 3
    Save back to Apple photos - you will (quite randomly) get the message in Apple Photos that the edited photo cannot be saved.

This bug was also there with earlier versions of TPAI but there it could be quite easily attributed to photos on portrait mode.
Now there doesn’t seem to be a clear pattern for that happening since I managed to edit photos in both portrait and landscape successfully but also had failed ones in both formats


Topaz Photo AI [v2.0.0] on [MacOS 14.0] Mac Studio M2 Ultra

1 Like

Hello, I also seem unable to save images back to apple photos, not getting an error message, it seems to have saved ot somewhere, but I cannot find the edited image?

Exactly the same problem here. The photo edited in Topaz Photo AI 2.0.0 from Apple Photos, when saved is NOWHERE to be found in Photo’s Library. But before you close the edited image in Topaz, you can ask to show the file in Finder. And it appears under a crazy path:

/Volumes/“your Hard Drive’s Name where the library is stored”/library.name.photoslibrary/private/com.apple.Photos/ExternalEditSessions/C981A12F-EA63-4570-9935-90CD6ED40E94/image_name.jpeg (and a second one .TIFF)

Obs. C981A12F-EA63-4570-9935-90CD6ED40E94 is just a random name for a folder, in your case it will be different

Now…the original image has the same name, but 2 different extensions .TIFF and .JPG In my case the file name is IMG_9455 (in Apple Photos it has the .HEIC extension thus IMG_9455.HEIC). Now in that folder with the crazy name, I find 2 files: IMG_9455.tiff (102MB in size…I quess that was the file exported before editing) and IMG_9455-topaz-denoise-enhance-5000w-sharpen.jpeg at 19MB).

My guess is, that when you choose to edit an image in Apple Photos with Topaz, the app first exports a a MASSIVE .TIFF file, then Topaz imports it for editing, you edit it, save the edited image as JPG with the appended -topaz name. That is saved in the same folder as the .TIFF image. But both images DO NOT APPEAR back in Apple Photos.

This is a nightmare and if you are not aware, disk space will soon become an issue. This needs to be fixed ASAP. It’s almost a crime in terms of free hard disk space wasting.

I also added a very unique and specific keyword in the image before editing. This keyword is wiped from the metadata in the 2 new files buried in the finder. Using this unique keyword in Apple Photos finds and shows only the original file.

2 Likes

I also have exactly this issue, the only (bad) workaround I have found is to saved a copy of the edited file elsewhere, import back in to apple photos then delete it from where it is saved - clearly NOT a sensible long term solution, but does save disk space whilst the issue is fixed.

2 Likes

…just imagine if everything in life had to be like this? Or every app? For example, Apple Pages: you save a file and expect it to be where you saved it, but it’s not there. Then manually search/dig deep into Finder, copy it to the desired location, and then go back, deep in the file system to delete the duplicates. Ah…and figure out which is the edited version.

1 Like

Simon, I figured it out!

Open Apple Photos > choose a photo to edit > Edit in Topaz Photo AI. Just for reference, first check the file extension .HEIC in Apple Photos and the original resolution (2666x3209 in my case).

Edit in Topaz and then SAVE. On the next dialogue box in Topaz, disable “Add applied filters to filename”, leave the SUFFIX field empty, turn ON “Allow overwriting?” In the Screen Shot notice that the file being saved is .JPEG (it was .HEIC in Apple Photos).

Miraculously, with that “overwriting” option, Topaz saves the image with the adjustments (I upscaled the file to 6000pix on the wide end)…and Topaz kept the .HEIC extension (after going through .JPEG). Now the edited file in Apple Photos is the same, same extension .HEIC, same metadata preserved, camera info preserved, GPS coordinates preserved, etc. But now at 6000pix + the Topaz edits.

Last, but not least, there is a useless .JPG version of the photo in that weird directory, but I guess it’s a cache file, that will be deleted someday by the system. At least it’s a JPG and not a 1.2 TB .TIFF file :wink:

I hope that helps!

Regards,
Kosta

Are you using the Edit with > Topaz Photo AI option? This will open Topaz Photo AI in stand alone mode, not plugin mode which can cause issues with the save.

The Apple Photos plugin is supposed to work like this:

@jo.vo I have a developer working on the unable to save back to Apple Photos error this week.

1 Like

@kodilu this solution worked for me fully - yours definitely worked on one level, but did overwrite all the RAW file so you couldn’t go back to the original / make other changes if you wanted to.

I would say, and have replied on my other thread re this that it really needs to work when you right click on the image itself and select edit in Topaz, or have that option removed if it cannot work!

thank you so much for your help :slight_smile:

1 Like

I asked my team if it is possible to remove the Edit with > Topaz Photo AI option by default. We will look into it.

1 Like

TPAI 2.0.2: Saving edited images back to Apple photos still fails, but now again with a clear pattern:
Landscape images are OK, portrait always fails.

1 Like

Thanks for the update. The plugin developer is out right now but I am hoping to get him working on it once he’s back.

In TPAI 2.0.3 the issue seems to be solved.

Can anyone else confirm if the files are saving back to Apple Photos correctly when using the plugin or if the error still appears?

Problem NOT solved, it only seemed so.
If you do an edit like cropping in Apple photos to the photo before sending it to TPAI it’ll save successfully back, otherwise not if you have a portrait orientated photo.

See my much more detailed report here:

1 Like

Edited the title to reflect the actual version number

Anything new here?
Is this going to be fixed sometime?

If it won’t save portraits, why not rotate the image 90 degrees?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

Hello,
when I use Topaz to edit photos inside Apple Pictures on my Mac, from time to time I get this error message trying to apply the changes:

Bildschirmfoto 2024-01-08 um 11.20.20

It says the changes cannot be saved, because there occured an error while saving. Try again later.
After that all changes are lost.

Any idea what I can do?

Regards, Christoph

That’s a known and long standing bug. See also e.g. here: