Topaz Video AI v3.4.1

(Update) So the below issue (see from “(Original)” on) was from running TVAI from the checkbox at the end of the 3.4.1 installer. I exited and used the desktop icon and a dialogue appeared:
image
Which then did a big bunch of stuff and I got an activated window when it finally appeared. Perhaps don’t have a “Run” checkbox in the Installer if you may not get a functional instance?

(Original) So after I installed this it comes up in Trial Mode (not uncommon, however I’ve never owned software that reverts out of licenced mode regularly as a security thing). Clicking on “Trial Mode” then “Activate” says “Opening Browser” but nothing opened anywhere. I logged into my Topaz account and have been looking around, but I can’t see how to activate it. It subsequently said “Sign in with Browser” after I’d written this, but again clicking gives “Opening Browser” (which is open already, plus still says to click the now-replaced “Activate”) and still nothing happens. Any ideas pls?
(Win10 Pro 22H2 x64 Chrome is the default Browser - this has worked many times before)
image
image

Ok,
so after a bit of experimentation with the “intermediate resolution” feature,
here are my results and an really easy-to-implement request!
4x gives the best results by far!

But…

It comes with a heavy price as it takes more than 5 hours to convert a 22min 640x480 video and up-scales it temporarily to 2560x1920,
before down-scaling it to the final resolution of 1020x680 that I set as target.

My request is to add the a 3x intermediate resolution option in the drop down menu that is currently missing!

The result is still great by it takes almost 40% less time than 4x!

Now that the developer Beta 6 of Sonoma is out the Iris bug in all TVAI 3.4.x versions is still there.

I may be wrong, but I think each AI model name, has three versions: 1X, 2X and 4X. They would need to make new 3X models for each named model… …and if they did, it would look different than the 4X version results you like.

The 1x 2x 4x is just an upscale factor.

It is literally taking the original video resolution and multiplying it by 1, 2 and 4.
Its not model specific.

They just need to add one more option that multiplies the resolution by 3.

And I know the results are good because I tried this by upscaling a video by 3 using Handbrake (another program) and gave that to Topaz to denoise and enhance.

I have to disagree. If that was the case, the results I got would not be so obviously different.

1 Like


Great result!!!

1 Like

You’re right. The Iris 4x model is a seperate model (that is also dl‘ed separately) that delivers distinctively different results from the 2x model.
And you can also see this in the fact that the serious bug that makes Iris 1x and 2x totally unusable on MacOS Sonoma isn’t there with the 4x model.

But then I do like the less pushy 2x model more, but that’s just my opinion.

Hello!?

I went in to setup the 2nd enhancement in settings and after I did it said “Trial Mode” at the top.

I’m a current registered user with a valid license.

When I tried to Activate, it says it is going to launch my browser to verify, but doesn’t.

My default browser is/has been Chrome.

It has worked in the past.

I tried setting the default browser to Firefox, but it still didn’t verify launch browser.

I was stuck in a loop of it saying “Trial Mode” and Topaz AI not launching my browser to verify license.

I also restarted windows.

For troubleshooting I tried re-installing the latest version again (v3.4.1) and choose “repair” and sure enough it verified the license and no longer says “Trial Mode”.

Just fyi, thought you might want to know.

Mike in Dallas
Win 10 Pro/64bit
All windows updates current (updated yesterday), Chrome version & Firefox version updated and latest Nvidia game driver installed

Hi!

I just posted about this happening to me as an “fyi” and how I was able to get it out of trial mode after choosing “2nd enhancement” under application and it set my Topaz to “Trial Mode” also.

Same thing happened to me.

Try to re-install the download for v3.4.1 and choose repair after you restart windows.

This was the fix for me, since it wouldn’t verify the “trial Mode” and I was stuck in a loop of it saying launch browser with it not launching browser (it did work in the past).

I also restarted windows first.

Hope this helps.

Mike in Dallas.
Win10 Pro/64 bit, Chrome/Firefox current, all windows updates as of yesterday

Just for reference, each model does have a 1x, 2x, and 4x version, you can find each version in the models folder. They can not natively do other resolutions scales (E.G. 3x, 0.5x, etc). When you select a scale that isn’t 1x, 2x, or 4x, TVAI will simply use one of those models (1x, 2x, 4x), then use a simple lanczos rescaler to get to your desired resolution.

For example, if you select 3x, TVAI will upscale to 4x, then use lanczos to downscale to 3x.
If you select 2.3x, TVAI will upscale to 2x, then use lanczos to upscale to 2.3x.

You can verify this yourself by selecting a scale other than 1x, 2x, 4x, getting the command used in exporting (Top of TVAI -> Process -> Show Export Command), then removing the simple scaling filter that happens after the AI model. Once you process that video, you will see it’s not the resolution you selected. It will be 1x, 2x, or 4x of the original video.

Also, many of the models have a scale input in the command line. By default it’s 0 (auto) and TVAI specifies the output resolution and the model automatically picks the scaler to use. If you set this scale to something other than 0, 1, 2, or 4, it will come up with errors. Something like: “Model only supports scales of 1, 2, or 4”. At least that’s what I remember from a few months ago.

2 Likes

Thanks for the update.
Just wonder why my preset will be gone every time the software updated.
And is it possible to have an option to save the processed video to its origin folder instead of preset folder ?

Trying to do a slow-motion enhancement and the model is taking forever to download. Previous versions its been okay but something doesn’t feel right here.

I did not know this was added! Oh this is great and changes a LOT for me in these remastered of much older garbo quality videos as doing the proteus/iris pass first THEN the gaia is returning WAY better results than throwing them all together previously. Mind you it cuts my fps processing speeds easily in HALF and hits the cpus even harder, but being less work and I only have to do settings once this is well worth! Went from about 2FPS (give take) to around .7FPS, but again I was not about to do the stuff twice so this is awesome. I cannot beleive Topaz did not highlight this as a MAJOR new feature!

Thanks for taking the time for the quick and easy write up with examples!

You think correctly, I also said about this in the same way that it would be logical, but at the moment the program interface is made completely inconvenient and illogical. Now, the intermediate resolution is specified in the settings of the second pass and it should be for the first one. This is correct for the programmer, but completely confusing for the average user, because logically this setting should be in the first pass window. See how, for example, the moment with adding and using filters is implemented in the old free program (which is already about 20 years old).


Everything is logical and understandable there, you can add any standard or external filter from another manufacturer in any order, move it to the beginning or middle as you wish, temporarily enable or disable the option during configuration and immediately see the result in the second window. I would like TOPAZ to make it possible for users to connect various filters in such a standard version for users, and not have a rigid binding to the sequence as it is now. In fact, TOPAZ is now slowly approaching the standards for video software interfaces that have been used for decades for video editing.
In addition, being able to use FFMPEG filters, and add them like in this old program, the possibilities of TVAI would be endless!

It is possible to make a modular design of filters consisting of models and FFMPEG filters, consisting of technical sets of FFPEG commands for TVAI, which could be added and edited independently or exchanged with users with new options. For example, a file (deinterlacing.tvf) with content similar to the one suggested by the user:: 20rushtonj Alaska
-filter_complex scale=w=HALF_INPUT_WIDTH:h=HALF_INPUT_HEIGHT:flags=lanczos:threads=0,tvai_up=model=DEINTERLACE:scale=1:device=X:vram=X:instances=X,tvai_up=model=UPSCALER:scale=0:w=OUTPUT_WIDTH:h=OUTPUT_HEIGHT:device=X:vram=X:instances=X,scale=w=OUTPUT_WIDTH:h=OUTPUT_HEIGHT:flags=lanczos:threads=0,scale=out_color_matrix=bt709

Make a filter section where filters would be taken from a folder in the program, and through the content list they could be substituted before any of the models or after and add all this in a different sequence and number. At the moment, there are only two models with a rigid binding to the program settings.

At the moment, in the description of FFMPEG filters, there are about a hundred examples and video processing capabilities, including all types of deinterlacing, interpolation, working with frames and sizes, as well as color correction, including colorization of black and white images… This is a huge database of filters that will replenish and improve constantly. Together with TVAI models, this would be simply an indispensable tool for video processing.
Description of filters and commands is located in the folder with the program: C:\Program Files\Topaz Labs LLC\Topaz Video AI\share\doc\ffmpeg (ffmpeg-filters.html)

1 Like

Can anyone confirm whether RAM speeds makes a big difference in export times? I have 4080 with 128GB RAM 3000mhz, I would’ve went with a 4090 but after some research it seems there wasn’t a big enough performance gain between the 4080 - 4090 on Topaz, maybe 20% so I saved money and went with the 4080, didn’t see the point in spending an extra £400 for 12-20$ gain.

I was thinking of upgrading my ram to a higher speed but wasn’t sure if it would be worth it.

1 Like

add pls 240 fps :pray:

Discus - I think Topaz should stop releasing new major versions of Video AI for a while.

(Note I have a support subscription that is good for the time being.)

I, along with presumably most people here, bought TVAI as a released product, but it continues to be somewhat Beta and to have some basic functionality that doesn’t work acceptably. The obvious example is the Preview pane. However people whose support contracts run out find themselves never really having received a solid product but more being beta testers, and are now asked to pay to get functionality at a level they would have expected to have when purchasing a released product in the first place.

I think a short list should be made of key features that anyone buying the product would have assumed would work with acceptable functionality, or to be promptly fixed during their support period, and no-one should be charged for upgrades until those items meet that criteria.

The system exists for paid and unpaid upgrades controlled by which part of the version number increments, but big limitations with the product, that customers would reasonable expect not to exist, are allowed to linger as future paid upgrades. So, IMHO, make a short list of a features any reasonable person would expect to work to a usable degree and only release minor (i.e. unpaid) version updates until they do. I think charging people to get basic features that they would have expected to work in the first place is not a good way to go, especially now people can’t say their software products are not warranted to have any functionality at all (as was the case some years back).

8 Likes

I know I sound like a broken record, but here goes…

Topaz should have continued to improve upon Video Enhance v2.6.4, rather than ending its life. I still don’t understand why Topaz Video AI v3.0.0 was v3, and not v1? Until the untimely demise of VEAI, I upscaled 172 episodes of Star Trek Voyager, 3 different times. I was “chasing the high,” if you know what I mean. My craving for an even better upscale, I started the 4th iteration with TVAI. The results were awful, even worse than before VEAI v1. Even though my license expired, I continue to read the forum hoping for eventual improvement, but have yet to see anything worth the cost to renew my license.

4 Likes

The latest update seems to get my process stuck at 100% and doesn’t “Complete” the job. Not sure what changed that can cause this.