Topaz Video AI v3.0.7

Anyone know when 3.0.8 will be released?

And will it fix.

  1. unable to activate license after uninstall/reinstall - it asks for browser but never evidently contacts/activates via license server.

  2. RTX 3080ti Proteus model fails on 3.0.7.

Reduced to using 2.6.4 but audio fails to come across on it a lot.


Below does nothing and will not activate license after uninstall/reinstall in order to try to fix “model failed” in 3.0.7 using RTX 3080ti - card.


If you have Aftereffects on Mac, an excellent and powerful plugin for dust and noise removal is Neat Video. I would run it through Neat first, then run the result through TVAI.

1 Like



The reason I believe that TVAI opens the webbrowser like that is to check if you have logged into Topaz via the web with the same email and password. It can use this as a validation for the software. One of my machines I had not been on the website before and when I installed 3.0.7 I had to login. It opened the web browser, I gave it my credentials, validated them and then closed. This was introduced in 3.0.7. My other machines never asked me to login when I installed 3.0.7 on them. They might have done the same thing as yours did and I just did notice it since my browsers were already open. If you save the password in your browser then the cookie associated with the website has a password validation selection. All just a wild guess on my part.

Screenshot 2022-12-17 095827

1 Like

Yes, fixed. They had a server outage. Should be good again.

That was never broken. :slight_smile: Has always worked on my RTX 3080 Ti. People have reportedly had good result empyting the models folder, and letting TVAI download them anew, as it would seem they can get corrupted.

EDIT: I’ve also seen said error in connection with un invalid/unverified license (for whatever reason). So, I’d say, try and get your login issue resolved first,

1 Like




When I emptied the model folders at:

c:\programdata\Topaz Labs LLC\Topaz Video AI\Models\ it then makes me try to re-license 3.0.7 - but it will not do.

I think due to licensing process changes in 3.0.7.

I think “Emptying the model folder” is not probably deleting everything in that path\directory like I did on reading the “solution” here is not a good fix, at least for me.

Is this the right folder and do you delete everything in it?

Also does it matter if Topaz AI 3.0.7 is closed or open when you do it?

But, why are the models now suddenly getting corrupted?

An uninstall/reinstall of 3.0.7 should fix this except for the License server issue that keeps you in trial mode & won’t verify license.

I tried this.

  1. Uninstall 3.0.7
  2. Install 3.0.6 from previous download archived version - (you probably can download it if you didn’t save it from - Topaz Video AI v3.0.6 )
  3. Go thru licensing - no issue with 3.0.6 licensing version vs 3.0.7
  4. Set directories/parameters in 3.0.6
  5. Close 3.0.6 and install 3.07 from downloaded full version that I archived.

Models now not failing (first time ran) and licensing in place for the first usage.

The second usage of Topaz 3.0.7 with a new file I still get “Model failed” again now. :frowning_face:

I don’t understand what is happening to corrupt the models since all I’m doing is running 3.0.7 again like I did before on previous versions of Topaz AI.

This “model failing” needs to be looked and is happening automatically & too easily.

But again, this software needs to be more robust/tested for 1) Models failing 2) Licensing for 3.07.

:arrow_down: :arrow_down: :arrow_down:

Uninstalled 3.0.7 again…

Installed 3.0.6 from archive (you can do via Topaz Video AI v3.0.6 if you don’t have archived)

Running 3.0.6 now - No model failure - No problems licensing…

:arrow_up: :arrow_up: :arrow_up:

Waiting on 3.0.8, to test.


Here’s the enhancement’s I’m using below - when this occurs. On files 720p/sub 720p to same size resolution prior to upscaling.

1 Like

Try Diamont, PfClean or Filmworkz.

There’s also DaVinci.

A lot of software out there. I’m seeing low budget titles being advertised although I have not used them.

We prefer PFClean.

I don’t know what industry you are in or film scanner you use - so check them all out.

Yes, I agree. I use between 2 and 4 :grin:

Yep, that’s the correct folder alright.

For some reason, I get the impressen you’re still not logged in properly. I think you’re running into that makeshift solution they had in place, where they said you could temporarily log in, but doesn’t consider your credentials as fully validated. I know, that sounds vague, but they didn’t specify what their ‘workaround’ exactly entailed.

They aren’t, at this point in my estimation (unless you have a broken disk or something). Must be the licensing issue. My models have never gone bad. And you really shouldn’t have to go through this. You did everything right, near as I can tell. At this point, I would just contact support directly, and get the license issue squared for you, because it’s highly unlikely your models are truly getting corrupted each time.

You can also enable extended logging, btw. This too may give you some clue as to what is happening.

One of the characteristics of MPEG is that it is lossy by design. A lot of the compression algorithms get more compression by rounding what are essentially irrational numbers., like Pi, for example, Unfortunately, this means that playback will never be 100% of the original. Attempting to resolve the problems by attempting to do too much decompression only results in excess noise and distortion. - In other words, the playback “artifacts” are there by design and will never be entirely reversable.

Then there is the older problem of transcribing media that was originally on film to MPEG for DVDs, etc. Often that means the grain of the film is often 'baked" into the original mpeg image as ‘detail.’ Also, older videotap originals frequently suffer from noise due to a combination of the light sensitivity and analog interlace from the older cameras they used. - Deinterlacing, denoising and resharpening is a genuine challenge and TVAI does it better than anything else I’ve used yet. - It does so by recognizing what was in the original image and essentially replacing it with information it has ‘learned.’

If you push it too hard, it will be forced to adlib or 'fake it." So, one of the little tricks in getting old, noisy stuff deinterlaced, denoised, and sharpened is best when done so by degrees. and using intermediate levels of enhancement during magnification.

Images tend to get sharpened better as the size is increased. Sometimes attempting to go from old SD directly to FHD in “one swell foop” will give poorer results than resizing and enhancing in two or more steps. - In either case, being able to effectively deinterlace and denoise at original size is the key to better enhancement while upscaling.

In passing, there is one thing TVAI needs is a deinterlacing function with denoising capability


“But, why are the models now suddenly getting corrupted?” - MichaelX

"They aren’t, at this point in my estimation (unless you have a broken disk or something). Must be the licensing issue. My models have never gone bad. And you really shouldn’t have to go through this. You did everything right, near as I can tell. At this point, I would just contact support directly, and get the license issue squared for you, because it’s highly unlikely your models are truly getting corrupted each time. - meimeiriver

I don’t know if they are actually getting corrupted, all I know is that a second run of 3.0.7 gets “model failed” and that other people here have said that it’s corrupted models.

Installation of 3.0.6 is running fine with no “models failed”/ no inability to license.

No disk issues - Using SSD 980 Pro Samsung (chip style) - SFC /scannow fine, Chkdsk /f ok.

I could also test/boot to SSD Samsung 870 or 860 clones of system drive (SSD 980 Pro) which I could do later & test 3.0.7 for these issues, but I think the same things will happen.

Like I said, failed models/licensing issues not happening on V3.0.6.



(For the Windows 10 version) There is a bug with the edges of the application window: even when maximized to fullscreen, I get the double-arrowed resizing cursor when I hover over the sides of the window. This becomes very bothersome when trying to use the scrollbar with the mouse cursor because it keeps going into resize mode.


Food for thought; pre-emptive noise.

I’ll give it a shot…

Somehow, I suspect that this may have something to do with corruption from the current or previous on-going Beta versions. I was assured by someone, can’t remember who, that they wouldn’t conflict with each other, but I suspect that was not entirely true.

Anyhow, since I cleaned out the Models cache, the problem has gone away and I’ve actually gotten some stable exports again. And it appears that this version is slower, but at the same time a lot of the recognition tools work better.

And, to me the main objective is better output, even if it takes longer.

1 Like


“Somehow, I suspect that this may have something to do with corruption from the current or previous on-going Beta versions.” - pdwhite

When I did a complete uninstall via Windows add/remove of 3.0.7 with delete setting/configurations, the models directory seems to be entirely deleted.

I then installed 3.0.6 without running it (just updated settings) and immediately upgraded to 3.0.7. A first run of 3.0.7 didn’t have “failing models” and pulled them in but if I run it again it using the exact same parameters/settings subsequent runs I get the “failing models” on a second run.

How are older models/beta versions getting pulled in using the above steps?

I would think that only those associated with 3.0.7 would be pulled in and especially since they work once then get “failed models” for me.

The only thing in the back of my mind is maybe it’s trying to pull in the same models, but the existing models pulled in previously are write-protected somehow and can not be overwritten or accessed for some reason?

I do normally run 2 incidences of Topaz AI on the same computer for different files at the same times but using same models - maybe the first incidence has them locked.

I don’t remember if I’ve ran one at a time, completely exited 3.0.7 when it was finished and then started another one - I think I did, but I’ve tried a lot of things in last 24 hours.

Also, I really don’t know why it would have to pull in the models again if I use the exact same setting and exact same parameters.

Shouldn’t it see if I already have the needed models in the directory and then download them only if necessary?

Just curious.


In pre-3.0.7 version, in the log, I see a line like

Checking for authentication at "C:\\ProgramData\\Topaz Labs LLC\\Topaz Video AI\\models/auth.tpz" 
Success: License expires on 2023-01-14

Now it’s just

2022-12-16 11-05-37 Thread: 6328 Info Login response Success: logged in

So, maybe that last line should show up in his log too?

As it turns out, the login problem had nothing to do with the model problem. However, I had recently installed the .0.7.0B beta, and when I update the released v3.07, it would not allow me to utilize some of the ehnancers at all. I only succeeded in this when I went into the models folder and deleted all of them. That forced TVAI released v3.07 to download the models it needed. Since then everything has been peachy. The login/watermark problem went away when they got the user server back online.

1 Like

Beats me. But it works. Although I haven’t tried running the beta version since installing the new v3.07 released version.

That’s what I suggested to him (a few posts up), but he said he tried that, and it didn’t work for him. :frowning:

i get this message 2