Topaz Video AI v3.0.5

It’s likely there is something on your system that is blocking Video AI from accessing the Internet to talk to the Topaz activation server.

This is not Topaz’s problem.

I recommend you use Google and find out how to create a firewall exception for Video AI.

Please can we have ProRes 444 (and ProRes 4444 to preserve alpha channel) in Windows too. It was advertised as having this but it doesn’t exist in Windows.

First time user here…

I am trying to deinterlace HDV footage (.mt2 files from the Canon HV20) and Topaz constantly crashes when I try to export.

Is this a known issue?

I hope they add it quickly, because the current version is absolutely useless without 2.6.4’s grain controls. Honestly, I’m REALLY pissed that I spent money on this beta crap.


How do I judge the quality of the improvement if the preview input window shows a different frame than the output window?
I only have this issue on the one video so far.
On Export windows is ok. On 2.6.4 preview synchro is ok.
Win11, RTX3050, Ryzen 3600G


It could be to low GPU memory. My other computer does the same. I think the limit is 4gb.


all videos uploaded with 60fps appear on youtube with 30fps… :sob:

I’ve tried a variety of videos and files, nothing works. Below is an example of the errors I’m getting. I installed 2.6.4 and have no issues.

When generating previews, I’m getting the following errors using the following settings.

Upscale to HD Resolution
Enhancement - Progressive.
AI Model - Fine-Tune/Enhance

When attempting preview

  • Error message from AI engine: model failed.
  • Error message from AI engine: model failed.
  • Error message from AI engine: model failed.
  • Error message from AI engine: model failed.
  • Error message from AI engine: model failed.
  • Error message from AI engine: model failed.
  • Error message from AI engine: model failed.
  • Error message from AI engine: model failed.
  • Error message from AI engine: model failed.

When attempting export:

Unknown Error
Last FFmpeg messages:

-vsync is deprecated. Use -fps_mode
Passing a number to -vsync is deprecated, use a string argument as described in the manual. Permission denied

Not sure, but looks most like what happens when I try to output to a ‘tighter’ security folder in Windows. Like Program Files.

Hello guys,

I managed to identify the problem of videos with a framerate of 60fps that youtube only recognizes as 30fps, the videos generated by Topaz Video AI really have 60fps but with variable framerate, if I upload these videos to youtube they will be recognized as 30fps. I reconverted those same videos with Handbrake and the final file has a constant framerate of 60fps, this difference between constant and variable is what makes youtube not accept the video as 60fps. Could you correct this attribute in the generated video? or at least give an option to generate as constant framerate?


If you have an nVidia GTX card and you’re encoding to H265, there is an issue right now with that. Try H264.

1 Like

Any chance we could get an option to close the program without confirmation if there’s no job running?

It gets tiresome being asked each and every time if you really want to do the thing you just requested.

1 Like

Would like report “unknown error”

When: simple format conversion (without interpolation or anything). No matter what output settings or file format. No matter its CPU or GPU processing. No matter of source video format.

After back to 3.0.4, all files convert without issues - i have idea that maybe something with nvidia drivers? But will not move from studio drivers - devs should check if their solution works on official stable drivers dedicated for production (as production oriented app). if issue is not with drivers, then no clue. Hopefully 3.0.6 will fix that issue

so there seems to be an issue and its been happening in v3.

when im using anti aliasing, it will only work if i upscale the footage. and i have to do that if i need to use the same setting again when loading the exported file.

which is irritating, because i dont want to have to upscale if i dont want to

edit: so just checked the initial rendering to 4k with anti aliasing. and the setting screwed with the speed of the footage, ie the fps is the same, but the footage is rather slow

so thats near 4 days wasted

Same here…

I definitely want subtitles considered in future updates.

I searched on this Topic for Topaz AI and ran across the below.

I haven’t tried it yet, but am upscaling a file right now that I enhanced first and need to extract the SRT from the original file & add back to this enhanced then upscaled by Topaz 3.0.5. file.


Someone posted on this previously:

Just use MKVextract to extract your subtitles file then remux with MKVmerge.

1 Like

Hmm, what’s your definition of ‘tinkering’? :blush:

As far as anti aliasing which model are you using. Here are screen shots Artemis and Proteus both set to Output Original size(100%). Also I would suggest always doing a short test clip using trim before doing a very long processing session.

1 Like

If you use MKVTookNix Gui you can do the this all in one step. Load both videos in to the tool, select the video from TVAI Deselect the audio from the same file. Deselect the video from the original and leave the audio, chapters and subtitles selected. Now mux. You now have the processed video and the original audio, chapters and subtitles.


I’d also like either it to always output constant frame rate or at least give an option to output constant frame rate (the source videos given to it have constant frame rates). I don’t think the video enhance AI had this problem where it output variable frame rates. It’s not just youtube that doesn’t handle variable frame rate videos properly, After Effects/Adobe Media Encoder doesn’t properly handle source videos that have variable frame rates so it’s going to be an issue when using an upscaled video from Video AI in After Effects projects if they have variable frame rates (which video AI currently outputs them with, with no option for constant frame rates).

1 Like

Up-scaling Star Trek Voyager 3 different times, with each iteration a little better than before, is my definition of tinkering, which was fun. After the first iteration I realized Voyager will never look like it was originally filmed in 4K, but was misled into believing it would, based on all the hype before version 1 was released. With each new version, the episodes got a little better, which kept me motivated to achieve the perfect upscale, but with version 3, those hopes were dashed all to bits. Like other folks have said, why pay to upgrade to what amounts to nothing more than beta software. This is nothing more than experimental horseplay, with true AI upscale many years, if not decades away. If this was something serious, which produced incredible results, Paramount would’ve jumped all over this AI thing and upscaled Voyager long ago.

1 Like