Topaz Video AI v3.0.5

Runing PREVIEW command send files in a folder where we can see it and run our own video player. I love the idea.
BUT, i’ve noticed that every files produced look to be processed with an AUTO bitrate when I’ve selected something else like 60Mb/s.
Any reason for that or is this just a bug?

I have this problem as well. Any luck?

Happy to see JPG output because the full PNG are overkill sometimes. However, the default JPG quality is extremely low. Seeing very heavy blocking artifacts in the previews and output when JPG output is selected. A quality input, maybe in the “output” panel of the Preferences widget would be appreciated.


There seems to be a slowdown issue with the Mac Studio M1 Ultra that is not present in 2.6.4. After sometime the processing seconds per frame goes from about .3ish to .7ish going from 1080 → 4k. I’ve seen this with every version of 3.x so far. I use a M1 Pro and M1 Max and they do not have this issue. In fact after a couple of hours even the M1 Pro is rendering frames quite a bit faster than the M1 Ultra.

@yazi.saradest @gregory.maddra Uploaded Result Files .Includes Tiff Files of the Frames and Exr Too.

Above Shot Shows How PhotoAI Thinks if the First Frame Run PhotoAI on the TIFF Files Outputted by VideoAI as TIFF.

I am not sure exactly how much was attempted to be fixed between this Beta and release, so I will mention a few things again.

  1. Preview images are still desynced between left and right image, so a little disconcerting when trying to compare them.

  2. It may be personal preference, but there is no preview images at all on export. It may just be me, but if its intending to run for many hours, the preview export lets me keep an eye on it periodically and tell instantly if there is an issue, as well as catching problems with scenes. It would be good if the preview was enabled for export.

  3. The naming convention on exporting images is still a bit borked with the duplicating frame numbers.

  4. Quality still does need some work. When you have a face filling most of the original frame, you cannot get a much better opportunity to test how well it upscales for details, but Proteus auto does a worse job than the TV upscaling, and doesn’t enhance any detail. Tweaking the settings can help at times, but so far makes the image less natural than better quality.


I ran an upscale with adding grain with H265 and after it finished the file size was zero.

Only changed upscaling to H264 and it ran a similar time but outputted the file great.

This never happened on previous versions for me.

Don’t know if this was a one-off, will try more H265’s later.

Made sure Win10/64 Pro with latest updates & also Nvidia was latest game drivers/experience since I read about a recent update for Windows causing “stuttering” in games for Nvidia and MS issued a corrective update prior to updating to 3.0.5.

Any reason to run this on Win11/64 Pro (can boot to it) vs Win 10/64 Pro (my default mode)?

Also a question, since one instance of 3.0.5 running with either enhancements or upscaling (do videos in 2 steps - enhancement, then upscale) only takes about 1/3 of GPU of my 3080ti normally and not much CPU, why does two instances cause the 1st instance and the 2nd instance to run about 25% longer?

With the resources available I figure it wouldn’t effect the runtime of either, but are they hitting against each other with me seeing more than enough resources that I’d think it wouldn’t effect the amount of time to complete?

Just curious.


In 2.6,4, I could scale to say, 201% (to get rid of some odd black sidelines in the source), but keep the 3840x2160 output dimensions (essentially a minor zoom).

In 3.0.5, however, I no longer can. :frowning: The scale to 201% now results in a 3868x2176 output file. Yeah, that’s no good.

I can ‘solve’ this, in my case, because I output to ProRes 422 HQ, and can compensate for the oversize in my second VapourSynth pass (with x265). That is not a solution at all, of course, for when you want to output sans an intermediate output format.

1 Like

This is a review of ddv3

v2.6.4 is back to the original good image quality


v3.0.5 cannot output due to AI error

The image quality previewed only once is not beautiful

NVIDIA526.98 is installed

ddv3 is
Early version is good overall
hope to improve from there

1 Like

Been away for a couple of months so forgive my question if it’s already been answered.

What is the purpose of matching 2.6.4 quality? Isn’t the idea to improve on 2.6.4?

Although Proteus is generally much better than Artemis for faces, I still find a plastic look on facial features especially in distant shots where eyebrows and eyelashes look like someone has drawn a horizontal black line across the face.


I would like to pay my compliments on how fast this program runs on my new m1 Mac. I’d been running it on my PC with an rtx3060 and upscaling an old dvd to 1080p ran at .7 frames per second. when I got my new Mac, I copied a 1080p to the Mac to compare and upscaling the video to 4k is running at 2.7 frames per second and barely hitting the cpu at all.

I would like to add a feature request though. the video I copied up had srt subtitles in the file (I believe they are srt format) and I realized after it upscaled that its missing the subtitle tracks from the source. I think it would be nice if I had the option to copy subtitle and chapter tracks (or all extra tracks) from the source to the destination file.

Also is there any plan in the future to allow expanding the dynamic range from 8 bit to 10 bit when upscaling to 4k?

1 Like

Are there plans to put 444 in windows as well?

1 Like

That speed is very good. Is your Mac the m1 ultra, max, pro, or standard? Were you using the Proteus auto, or another model?

1 Like

x265 encoding is busted. (Tried nvidia and intel encoders)
Surprised QA didn’t catch that.

(Fortunately the x264 encoder is working so that is a viable workaround.)

UPDATE: It appears x265 encoding is working with RTX 30 cards.

Hello, I’m having two problems with Topaz Video AI.
I am using the latest version of Topaz Video AI v3.0.5 and also the latest nvidia 527.37 driver. 1st problem, it gives an error when I export with NVIDIA H265 (up to version 3.0.4 it worked). 2nd problem, All videos exported by Topaz Video AI 3.0.5 with 60pfs are identified on Youtube with 30fps when the videos are uploaded.

H265 is busted in 3.0.5, H264 works.

UPDATE: Appears to be working with RTX 30.

I hadn’t tried the Nvidia x265 encoder till just now with 3.0.5. I’m running Nvidia driver 526.47 with a RTX 3060Ti. I ran a 2 minute 624x352 AVI video/MP3 audio using Artemis MQ and no upscaling. First I used Nvidia H265 Main at Auto MKV and transcode. Then I ran the same video only changing to Nvidia H265 Main10.

Here are the MediaInfo results. The first is the Main and second is Main10. I have no issue playing either video.

BUG? I reported this in 3.0.4 and it still exists in 3.0.5. On a Mac, exports that have been trimmed (not starting from beginning of video), contain 3 to 5 seconds of blank frames at the beginning, when played in Quicktime player. However, previews are fine.

Click on the Youtube settings wheel and unlock the 60fps for your browser :slight_smile:

x265 Main (NVIDIA) works fine with RTX 3060

1 Like