Topaz Video AI v3.0.10

Hello Everyone!

A new release of Topaz Video AI is now available.

Released December 27th, 2022.

Download: Windows, Mac.

Changes from v3.0.9:

  • Improved JPEG output quality
  • Prevent mouse from clicking through dialogue box to background
  • Cap max processes count to 4 in preferences
  • AI error messages are only shown if the process fails
  • Misc. bug fixes and improvements

Known Issues

  • If you are logged in and recieving a watermark on Windows, try deleting the %PROGRAMDATA%\Topaz Labs LLC\Topaz Video AI\models\auth.tpz file while the app is closed.
  • If all models fail, please try deleting the .tz files in your model folder. The location of this folder may be found in the preferences menu.
    • Please reach our to our support team if the issue persists

Submit files here: Dropbox

Please take a look at the Video Roadmap Update for more context on what we’re focusing on right now. Thanks in advance for your feedback!


Can’t wait to get home to try it!!!

Happy holidays, everyone!


When I switch between the different modes and I return to Proteus relative to auto mode my adjustments I made earlier are gone. It would be great if the application would remember the settings for all modes even if I switch between them!


This new version takes an awfullly long time to start (from SSD). It seems to hang, for almost 30 seconds, then decides to show itself, after all.

I don’t see much to change with this version, you said that you put back the model manager as in version 2.6.4, where is it? What version will you give it to? Can we at least know? thank you


opening here in less than 2 seconds, and on two différent computers.


Error with Apollo:

Last FFmpeg messages: Unable to parse option value “0” as video rate


Does here now too. Guess there was an authorization delay somewhere, earlier.

On that note, loved that guy manually patching the command line for that 10-bit fmt parameter for ffmpeg + AV1. Bit-depth is, however, also something which should appear in a simple pulldown menu (when applicable for the desired output format).

All of a sudden getting this error… Pls help me…

They say, patience is a virtue.


If I have a powerful GPU and CPU, why would I want this limitation? A warning dialog might be more appropriate.

1 Like

Known Issues

  • If all models fail, please try deleting the .tz files in your model folder. The location of this folder may be found in the preferences menu.

If that doesn’t work, try contacting support on Topaz main website.

AV1 is not showing up for 7900 xtx gpu, anyway to update topaz enhanced video ai to include this codec for new radeon gpus? or is there a way to force this command?

It says that twice every time I run Apollo but processes the whole video fine. It has always said that.

Thanks very much. Its solved now…

at Export it throws the same Message and no File is saved

I only use the CLI and output to png. I have to use the CLI to run it at a slomo multiplier of 2.5, and I have to output to images so that I can encode them into the higher frame rate I want.

I did try the GUI and output to PNG still. It had no problems. I wonder if it’s a problem with the output container you have selected, but since it always says “Unable to parse option value “0” as video rate”, that’s the message you’re getting back.

1 Like

Agreed, why is 4 the special number for max processes?