Topaz Video AI v3.0.0

2.6.4 has the model manager in preferences, and you can download all models. For me, it didn’t work in one go… I had to go back in, open each model box, and select the models that weren’t downloaded completely. I did it one model at a time. So make sure you go in and open each model node, and make sure all versions of each model are showing with a check mark next to them. You may just want to do it one model at a time to insure it works best. I know that takes time, but it only needs to be done once.

For me, on a PC, this downloaded all optimized versions (480x384, 576x416, etc. etc.) for Open Neural Network Exchange for GPU processing (both the fp16 and fp32 optimized files for 1x, 2x, 4x-ox.tz) and Intel OpenVINO for CPU processing (fp16 optimized files for 1x, 2x, 4x-ov.tz). When the download was done, the model folder has 6,484 files at 190 GB.

VEAI 2.6.4 should continue to function like this forever. If you’re really paranoid you can block the program in Windows Firewall.

I believe the model files download from Amazon web services. I backed them up to pCloud… all 190 GB!

I’m actually an OpenVINO user, and VEAI 2.6.4 successfully determines and uses an OpenVINO optimized model (I believe it’s the 480x384 for me). In 3.0.0, the optimized model either isn’t implemented, or doesn’t work, and I only get the default 288x288 non optimized model for OpenVINO. It also runs much slower, and produces different results that I don’t like as much as 2.6.4.

You can “trim” the video with an in and out point, but then the trimmed version expands to fill the entire timeline so you can’t see where within the overall video you’re working.

The bigger problem is that if I wanted to extract 2 segments from a video, I would add the video twice in 2.6.4 and set the in and out points differently on each one. There’s no way to add a video multiple times in V3, however.

2 Likes

The models do not change?

My point is that this software is guaranteed to work for one year it appears because you only get updates for one year. You have to pay to get a new update.

After one year, they could decide not to support older versions and you might not be able to download a model anymore, then you must buy a new update.

So the EOL for this software is 1 year in my eyes.

That seems to work, I just tried it, but the results are different for each instance: 2.6.4 with default models, 3.0.0 with default models, and 3.0.0 with the 2.6.4 model files.

3.0.0 with the 2.6.4 model files produce even softer results than 2.6.4 or 3.0.0. I tested VEAI 3.0.0 with the 2.6.4 model files by just hitting export, and also by opening the command line and pasting the command with scale=0 changed to scale=2. It had no effect, the results were exactly the same.

Here’s an updated animated PNG (with correct 1280 x 960 dimensions now) that includes 2.6.4 model files copied into the 3.0.0 model folder. 2.6.4, 3.0.0 with 2.6.4 model files, and 3.0.0 all produce different results. It does appear to me that the 3.0.0 version of the model is a completely new or different version of the model.


(right click → view image for full size)
test_sample.zip (745.1 KB)

Here’s the model file information:

Topaz VEAI 2.6.4 model file:

Name: alqs-v2-fnet-fp16-288x288-2x-ov.tz
Size: 6498709 bytes (6346 KiB)
CRC32: A9F23519
CRC64: EBB87CD05D7884AD
SHA256: B5DA76517DEF55D353EAACE3FE1D2DB4C717C803097F87A9F78A3D177839B053
SHA1: 1DEA3904271992D9CE5CBDC83BC5211B48083886
BLAKE2sp: AE65023B0BD61F1C53D9CC1DCD62CE4D198493999BBDBC9A47E1C5928215EA82


Topaz VEAI 3.0.0 model file:

Name: alqs-v2-fnet-fp16-288x288-2x-ov.tz
Size: 6485195 bytes (6333 KiB)
CRC32: 92F4DC31
CRC64: D61B480997D53E73
SHA256: D56296CCC98366BED228ADC71F57A227026F40DEFBAC9C861E8B471C3E16E3B1
SHA1: 679DC9DBB5A061EB00407902C8A66874AAB30C4C
BLAKE2sp: 45A1DB834E858FF1BDDAEA81EA4D681952F5AFCD4BE52AADB5EBF7C894EE3A54



Topaz VEAI 2.6.4 model file:

Name: alqs-v2-gnet-fp16-288x288-2x-ov.tz
Size: 25944939 bytes (24 MiB)
CRC32: DCAA22AA
CRC64: A5C4968C25F2A70A
SHA256: D85280FE1FE7D5515E5A7664DA2085CB189A45CC8EAD66CA7ACB486F4595C781
SHA1: 088A7077BAAD93E31A735484EA80601D37833E02
BLAKE2sp: 34FDAFFF8B0D4D44E1BDA27E96B861D38CEFE9D0F6C6B11E2212602B0AF78F35


Topaz VEAI 3.0.0 model file:

Name: alqs-v2-gnet-fp16-288x288-2x-ov.tz
Size: 25898977 bytes (24 MiB)
CRC32: CF5AF205
CRC64: 590EE5FBD9369E70
SHA256: 1436805048ED6BFDA5BAC654E12E6E3367ABAD0185F9F9BE3E13D17E73C64DC8
SHA1: AC71385827652783A3B765EEBE3DBF1938E4F5A0
BLAKE2sp: 67A0390228C12E5F1FEF80F2C7D824189CEDB33783A54CF93B5E2158067840A5


Topaz VEAI 2.6.4 also has this model file, which seems to be the fnet and gnet files combined, which isn’t used by VEAI 3.0.0:

Name: alqs-v2-fgnet-fp16-288x288-2x-ov.tz
Size: 32453801 bytes (30 MiB)
CRC32: 70123CD7
CRC64: 396AE8450707C20C
SHA256: 6C9EF36CE113413BD983F144E33BCC258625E9F31021A6B2EDB8491172315185
SHA1: 5128E69EF903BFABF864C1BF1B97CC6D8CC0BF71
BLAKE2sp: A40D18B5B41256B7E9E53D6C316355E5646CC8BDCC999229F397025DC685DA65
1 Like

I only use Proteus V3 in both 2.6.4 and V3 on three separate computers. All three are AMD Ryzen computers. I mostly do 540 to 1080 but sometimes 1080 to 2160. Here is a rundown on the machines and the VEAI speed in sec/frame. Currently I’m seeing only a very slight difference in speed between 2.6.4 and V3, 0.01sec/f in all the computers. Quality wise I still like 2.6.4 but that is because I use h.264 with CRF of 5. I average somewhere around 100Mb/s file. I then do what post processing I need to do. The hardware encoder route in V3 is fine for streaming or very poor original files. The hardware encoder in the AMD RX 6600 is poor compared to the Nvidia RTX 3060’s. Software encoding is still better than hardware encoders(IMO) in GPU’s but you need enough CPU cores to make it worth the time to encode difference.

Ryzen 9 3900x RTX 3060TI Windows 11 .11sec/f 540-1080 1080-2160 .41sec/f
Ryzen 5 5600x RTX 306012GB Windows 11 .11sec/f 540-1080 1080-2160 .41sec/f
Ryzen 7 5700G RX 6600 Windows 10 .17 sec/f 540-1080 1080-2160 .62sec/f

Well I sure want that to be the solution. I tried your sample, and no, I could not get the versions to yield matching results. I never use that model so I am personally less invested. I was able to get Artemis High Quality to match with my little number swap.
Your sample does not have the minimum 30 frames that 2.6.4 seems to want. (Maybe I made that up and it’s not quite that many.) Probably not related.

I tried a few more variations of the command. Nothing seems to trigger the model change for Strong Dehalo.
I love the idea of manual model swapping. No idea if I’ll ever get around to that.

with AI V3.00 when I process the video…after finishing a video , it repeats the entire process again and again. I have to check the finished clip to see if it is complete because the Topaz Ai 3 does not stop just goes on repeating the entire process again…is this an issue or what am I doing wrong…did not have problem 2.6 Enhance.

1 Like

Hi, I noticed that too, after the end of a treatment, it’s not over, it happened to me with quite long treatments, probably a check but I waited and it ended me .

When I input a 640x480 mkv source extracted from a DVD, it is judged as 720x480.
And the x2 upscale output is determined and output as 1440x960.
In ver2.6.4, x2 upscale (200%) was judged and output as 1280x960.
It seems that the width of the video is incorrectly determined.
Using Macbook Pro 14inch

No, they’ve not eliminated the ProRes 422 option (in the previous version there was just ProRes 422 HQ and in this version there’s ProRes 422 HQ and ProRes 422 LT). But in their promotion for this version they said it would (also) have a ProRes 444 option but it doesn’t have the ProRes 444 option they said it would. And I want that option (preferably with an alpha channel preserved, ProRes 4444).

I’m always using Topaz Video AI for long time (since first launch). My graphic card always = RTX 2070 Super. The v.3.0 release is rendering very very slow in comparison to the last V 2.6.4 version. I tried so far different settings in v.3.0 for export without any improvement of rendering speed. I hope, that a new v.3.0 version coming up soon with much more faster rendering (minimum as fast as V 2.6.4.
So I stay further with v 2.6.4 for the moment.

Can you test proteus v2 in 2.6.4 vs proteus v3 in Topaz v3. I am getting less artifacts with v2 idk why.

Ugh – I don’t get the reasoning. Why cherry pick the codecs?

Do they have to pay a licensing fee to use the ProRes codecs on Macs? They are already on the machine.

I wouldn’t think ProRes codecs would be used on PCs. They have plenty of their own.

I am starting to get an odd feeling about the “behind the scenes” with this software.

I am confused why this even supports MKV.

There is a demand for high-quality private videos saved on DVD.
In this case, mkv would be an excellent means to easily extract the source.

1 Like

MKVToolnixGUI is a free tool not by Topaz to merge together the video layer and the sound layer of two video files. Just drop in both files and select of which one you want to have the video and of which one you want to have the audio and then it will make a new file having both.

I understand MKV – it was very popular for pirated movies on the internet.

It just seems to me – stick with standard video format containers. If you want MKV – then use a tool to convert your video into it.

MKV just cheapens the software and it is not a widely compatible container.

I have no idea what market they are going after now. If you do MKV then let’s have a truly professional container – MXF. At least MXF is well established and excepted in the video industry.

I think you got way off track. I suggested MKVToolnix GUI for splitting a file into sections to then feed into Topaz. It has NOTHING to do with Topaz itself.

Ok - I apologize. This forum is difficult to to maneuver through. It just appears like an endless list of random responses. lol. Sorry.

2 Likes

this feature is planned for a future update. it’s on their roadmap.

1 Like