Topaz texture 2 filter not working

I have a new computer and I am using the latest version of photoshop.
I’ve installed the topaz texture effects 2 on the computer and it’s in photoshop, but when I use the texture effect… it opens, and it loads a bit, but it doesn’t load any further and then it shuts down.
I’ve already reinstalled the filter but still the same problem.
It does load all other topaz filters except texture effects. I used the texture effect a lot on my old computer, and never had any problems.
So hopefully you can help me with this.
Thank you in advance
Ange

Firstly it is an unsupported product as it is now a legacy product.

Secondly, does it run as a standalone?

What is the configuration of your new PC? Things such as the OS, RAM, GPU including vRAM and driver version.

Also include the PS version.

I was able to use it in photoshop before and it now opens in photoshop too, but it won’t load
I can also use it normally if I click on the icon on my monitor and it shows the same…not loading either.

PS Version 23.1.1

RAM 16.0GB
64-bit operating system, x64 processor

Device Name LAPTOP-JKI77ICE
Processor 11th Gen Intel(R) Core™ i7-11370H @ 3.30GHz 3.30GHz
Installed RAM 16.0 GB (15.7 GB available)
System type 64-bit OS, x64 processor

Edition Windows 10 Home
Version 21H1
Installation date ‎15-‎10-‎2021
Control System Assembly 19043.1526

Thank you for your response
Hopefully this is what you mean

Schermafbeelding 2022-02-14 134319

1 Like

Try updating your NVIDIA drivers from the NVIDIA website to see if that helps as the drivers you are using are out of date.

Strange that they are out of date. :thinking: :thinking:
I will try that…Thank you

I have a new computer, win 11, 64bit. I tried using Texture Effects but It starts and then stops abruptly. I understand that this program is unsupported but I thought I wouls ask if anyone had any helpful ideas. I tried using it as a standalone. Mt Nivida drivers are up todate. No error messages. 32Gb memory. Anyone have any helpful suggestions? Thank you in advance Bob

I have the exact same problem with my new computer. I guess you never got an answer?

My advice would be to check through the task manager to see what other applications are running at the same time and then stop them to one by one too see if there is any conflict.

In my case I have a PC running Win 11 and can call and execute both from hosts and as a plugin to AP.

I’m having the same problem too. Just bought a new computer (going from Windows 7 to Windows 11). I have been able to install PS 4, Nik and all of the Topaz software (including all the legacy programs and Studio 2).

Everything ran fine, except for Impressions 2, Glow 2 and Texture Effects 2) both as standalones and within PS. Studio did not load, but Studio 2 did. Studio 2 appears to work correctly, but when I save back to PS, you can see some transparency in the image.

I finally got Impressions 2 to work, by playing with my GPU. Turns out my computer has an NVidia GeForce 3050 RTX, and also has an Intel integrated graphics card too. When I changed my primary GPU to NVidia, Impressions 2 started working, but I don’t see any change in the other programs.

I’ve also done troubleshooting, and reverted back to Windows 7, since the programs worked fine there. That didn’t help either.

Any suggestions on how to get Glow 2 and Texture Effects 2 to work, and Studio 2 to work properly?