Topaz Studio will not launch a 2nd time from within Photoshop

You have to select Studio under filters and the flout contains impression

I am fully aware of that. But as I said earlier Impression does not appear as a Topaz Labs plugin. Yes it displays in Photoshop plugins but under Topaz Studio and NOT under Topaz Labs. I want to launch Impression directly as a Topaz Plugin and not via Photoshop->Plugins->Topaz Studio->Impression.

Just updated Topaz Studio to v.1.4.4.

Using Photoshop CC 2018 upon initial install of Studio update to v 1.4.4, Studio launched first time and a second time. But would not start a third time. Re-started Photoshop CC 2018 and it is only launching once. Same as v 1.4.3 & v1.4.2.

I also tried Photoshop CC 2017 which is still installed on my computer. It had the exact same results.

I too have just updated to v1.4.4 & also have no change to the , now, very third rate Studio still not opening after the first instance through Ps.
Gosh, why did I spend all that money for Ps plugins which worked great until Topaz figured they were better than Adobe. Very, very upset.


1 Like

I have just run an experiment. I can still access all the plugins directly from Ps just as it used to be starting them multiple times but, once I have opened a plugin I then cannot access any of the three updated ones through Studio. Once a plug in has been accessed Studio will not launch without a Ps reboot.
Great, eh???

Topaz Labs plug-ins are world class. And the reason why I became sold on Topaz Labs.

However I am not a fan of Topaz Studio. I want cool plug-ins that do tasks which either are very difficult to do in Adobe or can not be done.

I do not want a replacement for tasks which can be done easily in Lightroom or Photoshop.

Couldn’t care less if Studio has masking, curves, saturation or layers because I do all this in Adobe apps.

The only thing I want from Topaz is cool plug-ins that run natively from within Lightroom or Photoshop.

I’m losing patience with this Studio nonesense.


I discovered something that may be helpfull. Before I was working on a number of new files I shot the other day that I brought into Photoshop (through ACR) from the original NEF/RAW files … while working the files (some five files open in PS-CC 2017) I could use my personal favourite presets withing Topaz Studio on all of the files …

Just before I installed the latest Topaz Studio update … I then started reworking 5 exiting TIFF-files in Photoshop to make some additional changes to the files and layer-structures) … I could work from one of the layerfiles in Topaz Studio and appy the preset-tool I needed … I could not do so on the second file after finishing my processing on the first one and saving it and closing it from the PS-CC-2018 window …

main difference between the two sessions were the type and initial size of the files open in Photoshop …

first session 5 NEF/RAW files from Camera Raw into Photoshop … around 18-20 mb each …

second session 5 multi-layered TIFF-files from Bridge … around 650-900 mb each …

I suspect the problem could very well be related to some issues around the allocation of memory between Photoshop and Topaz Studio during these sessions …

my system is Windows 10 with 16 mb RAM and SSD 0,5 Tb …

in my workflow I also use On1 Photo Raw Effects during these sessions …

My issues were working on JEPGs and Nikon Raw files (.NEF).

My issues are with any file I try, DNG, TIFF or Jpeg. Makes no difference.

kenmo, I totally agree with your comments on Topaz plugins & the cheap & nasty Studio. The plugins are excellent, Studio…

Hi Joe,

Please see one of my “wordy” reactions further down below.

I have a feeling that part of the problem may have to do with the memory allocated to Topaz Studio as a plugin from Photoshop when opened more than once in a Photoshop CC-2017 (or 2018) session with more multi-layered (large) TIFF-files. I do not encounter a similar problem when opening apps from On1 Photo Raw as plugins in Photoshop CC. Seems they give back allocated memory better than Topaz Studio seems to be able to.

the same over here, w10 and ps cc 2018, were can you download older versions?

1 Like

I would love to download the Impression Topaz Labs plugin version and forgo all the Topaz Studio issues… Don’t need 'em, don’t want 'em…


het zou kunnen dat de volgende link naar eerdere versies kan leiden:

op de pagina kunnen de eerdere versies aangeklikt worden en er is een knop naar vorige versies …

mogelijk een oplossing

All my plugins are still as I downloaded them upon my initial purchases a year or more ago. All accessible directly from Ps.

As are mine for Simplify, Adjust, DeNoise, Star Effects, Detail, ReMask. But NOT Impression. It does not show as a Topaz Labs plugin. It only displays under Topaz Studio. When I purchased Impression 2.0 it was not sold as a Topaz Labs plugin. Only as a Topaz Studio app. I would muchly prefer it as a Topaz Labs plugin.

Ah, that is a pity. I just access the plugins direct totally ignoring Studio!!

Please remove your email from your name field as this is a public forum and anyone can see it …

@JoeFedric-TL can you have the developers look at this.

After investigation it seems that this bug is caused by creating a duplicate copy of the layer you are working on as you then don’t get the message warning about transparencies.

It means you can no longer call any plugins under the Studio option in the filter menu.

But if you use a locked layer and get the message Studio Plugins can be called every time.

Message for locked layer:

What? I do not understand your reply.

But let me explain. I do create a copy of any layer I am working before sending it to Topaz Studio or Topaz Labs. It’s just good practice to make a backup copy in case I do not like the results.

However… I have NO idea of what you are saying or suggesting.

It isn’t a suggestion on how you should do your editing, you are doing it the intended way, this bug seems to be caused by passing a unlocked layer, but if you use a locked layer this bug doesn’t happen.