Topaz Studio v2.0.2 update - 30/07

Topaz Studio 2 update to version 2.0.2 is now available! Here’s the change log:

  • Fixed Crash when Export or Saving back to Lightroom involving TIFF images
  • Filter Favorites List is now sorted alphabetically within categories
  • Studio 1 Custom Preset to Studio 2 My Look Conversion has been added to the Help Menu
  • Brightness / Contrast Filter has been added to the list of Filters

When we have crashes should we upload a trace log to a new support ticket each time? Or is there a better way to expedite? More interested in reporting than tracking issues at this stage.

Sure I would upload the Logs each time with a new support ticket but I also do the following each time there is an update, note I am on Windows so this refers only to Windows:

  • Go to “%localappdata%\Topaz Labs\Topaz Studio 2\Logs” and delete all logs to make sure that the logs are easier to read.
  • and, of course, make sure logging is on
  • each time I upload the logs I would delete, but it isn’t really necessary

Typically I do the same even for other products unless they want more info.

Glad of the arrival of TS1 Custom Presets at TS2 - patiently awaiting extra adjustment facility so I can tweak said presets - and ‘almost despairing’ that I will be able to share: if I had any hair, I’d already have torn it out!!! :wink:

1 Like

How do I update? Studio 2.0.0 has no automatic reminder when I open it and it tells me no updates are available. Where are the links?

1 Like

When I opened 2.0.0 a pop-up immediately displayed … so I d/loaded.

That’s what I expected to see, Jack. But no pop-up and no updates available when I click on check for updates.

If you d/l from the Shop - I know it says v2.0.0 - but Topaz have never been very good at updating the description once they have a new version in place?

Can we only import Custom Presets into Studio 2 once? I successfully imported my original 25 presets then did an experiment.

I went to Studio 1 and created a new preset. I then closed Studio 1, opened it again and my preset was definitely still there and I could apply it. When I tried to import this new preset into Studio 2, though, I just got the message that my original 25 had been imported. The new one didn’t show up under My Looks.

People who have imported their presets might still go to Studio 1 for things Studio 2 doesn’t have yet like the healing tool or crop. There’s no point in continuing to work in Studio 1, coming up with a great new effect and saving it as a preset if it can’t be imported into Studio 2 because import can only be done once.

Same issue here.

I suspect that your previously shared presets (lodged on Topaz Servers) are the ones legitimized by TS2. TS1 now remains unsupported. This was the case for me - my 5 previously shared custom presets (stored at Topaz) were transferable into TS2. The only thing they haven’t fixed yet is to be able to tweak and edit custom presets (as was possible in TS1).

1 Like

OK, that worked, I have v2.0.2 now. Looks like the update has gone off at half-cock again. Can play with it now.

I migrated my presets and it told me I had 126. I don’t have 126, I have about 20. Looks like it has migrated every single preset I have ever tried and deleted as well as the ones I’ve kept. It’s a mess that will take some clearing up.

It’s very annoying if that’s the reason. There are people still using Studio 1 while waiting for Studio 2 to get all the upgrades. There’s no point in them creating new presets in Studio 1 now if it’s not possible to import them because Studio 1 is no longer supported.

What do you mean Jack? When I select and apply my custom presets that were imported/converted from TS1 I can tweak them. Win 10

1 Like

Oh, my mistake - of course now I see - just getting used to where new to look for old familiar things! :slight_smile:

1 Like

After I apply a ‘look’ but decide I don’t like it, is there a way to go back to the original image? I am probably just not seeing it???

Just press the Trash Can on the Looks header … or, if you just want to turn it off the eye icon on the right will hide it.


Use the Bin icon - the one between the eye and the mask icons

My TS2 is importing Jpegs really too soft - somehow they lose their sharpness in TS2.