Topaz Studio v1.14.5 Login Issues

After update Topaz Studio to version 1.14.5, I have this problem: when I start the program, always is freezing for a while, and the program show me the login form again (for email and password) - even if I already logged on - but I cannot do anything because is freezed. After a few second, the program login itself and working normal… It’s frustrating because in previos version everything was ok…
I hope you will solve this bug in a next update…
Thank you

P.S.: My OS is Windows 7 (64bit).

Try going to Help-> Reset local database and see if that helps.

NOTE if you have any personal presets save them to a project file first by applying them to a image and then after the local database is reset open the images and resave your presets.

I did what you said, I reset the local database (Help-> Reset local database). Then, after I started the program again, the same problem remained: the program froze for a few seconds, disappears from the screen - while the computer is blocked, I can not click on anything! - after which the program returns and goes normal.
I’ve already uninstalled 4 times the Topaz Studio program - including with Revo-Uninstaller, and I deleted everything that’s left of the old Topaz Studio program - and I installed it again, but it does exactly the same, there’s no change.
I’ve updated all the others (Gigapixel, Denoise, Adjust AI, Sharpen AI …) and all works smoothly, only Topaz Studio has encountered this issue since the last update (1.14.5).


I believe the update is due to be released sometime next week anyway. If you are happy enough with using the registry editor I can send details on how to reset the Studio entries in the registry which may help. No need to worry because when you start the program it will recreate the relevant entries as it would when it was installed the first time.

Let me know if you are comfortable enough to try that.

I’m waiting for your instructions, here in the forum (for Windows registry editing), I’m convinced they will be good for other users as well. Thank you for your support.

LATER EDIT: I also have a question: I updated all Topaz programs, should be the latest versions … When I open Topaz programs, all shows me the correct versions, respectively I have the latest versions, instead, in the Windows Control Panel shows me other versions !! ??? Please see picture below:

And programs show:

Yes it seems the versions that are running are right but the list of apps in the install/uninstall are what i see in Win 10 also.

Thing to try before the registry editor is to select Community-> Switch Users and retype your email and password to see if that helps.

If it doesn’t help then …

OK, for the registry follow these steps, but only what I post here as it isn’t difficult and when you restart Studio it will revert to when you first installed it in terms of window size, may force a log out and any last opened etc. will no longer be there. So, this is what to do:

  1. type regedt32 in the search box on the taskbar, select it and press enter.
  2. on the left hand side of the window you will see a tree structure of folders.
  3. Click on HKEY_CURRENT_USER and expand it
  4. Click on the Software sub-folder and expand it
  5. Then click on Topaz Labs and expand it
  6. Scroll down until you see the Topaz Studio entry, right-click, select delete, say Yes and exit
  7. Restart Topaz Studio and see if that helps, it will take a while to update its resources but you can use it while it is updating.

If both of those fail, the next is to do the following:

  • Type %localappdata%\Topaz Labs\Topaz Studio\QML\OfflineStorage\Databases in the file explorer search bar
  • Press Enter
  • Select all files, at least 3, delete them
  • Restart the application and log in again

1.) - Community-> Switch Users - I did that, and did not solve the problem!

2.) - regedt32 > HKEY_CURRENT_USE > Software > Topaz Labs > Topaz Studio (& deleted!) - I did that, and did not solve the problem!

3.) - %localappdata%\Topaz Labs\Topaz Studio\QML\OfflineStorage\Databases > (& 2 files deleted!) - I did that, and did not solve the problem!

BTW: I found only 2 files here, not 3:

Always I get this freezing screen:

That screen shouldn’t freeze, you should be able to click on the username or password field, then the password field and enter that and click login.

No, It get freeze (I can’t click on the username or password field). Look here:

Thanks for the video, I haven’t seen anything like this before.

Is it possible for you to post your GPU details here when you next use Studio? Go to the Help-> Graphics info and click on it, then press copy and paste the info here.

Also check that the firewall isn’t blocking Studio please.

The only firewall I’m using is the “default” firewall of Windows 7. I turned it off. Nothing has changed:

My video card is:

L.E.: Topaz Studio 1.14.2 worked smoothly, without any problem (or 1.14.4, I dont know exactly what version was, but I know that always I maked updates when any update was released) … Perhaps it should be seen what was changed between 1.14.4 and 1.14.5 ?

The difficulty we face here is that next week there is a new version due out replacing Topaz Studio, it will be called Topaz Art Studio, and will be functionally similar although wont have all the functionality of the current version initially.

So there is no incentive to update the first version of Studio and I don’t see any real problem with your drivers, the game ready driver, so here is the changelog which will give you an idea of the updates:

The only previous version I can find is 1.12.6 and that can be downloaded from this link and it will delete the current version and install the 1.12.6 version.

I upgraded Topaz Studio 1 (v1.14.5) to Topaz Studio 2 (v2.0.0) where I see that A.I.Clear works well, so I consider the problem solved. I will stay with version 2, which works without freezing problems like version 1.

Thank you.

1 Like