Topaz studio slow opening - sometimes "not responding"

I made the mistake of upgrading to the latest version of Studio the other day and now everything is running way to slow or not even opening. my operating system is Mac High Sierra vs. 10.13.4 and information on my graphic card is Intel Iris Pro Graphics 6200. I checked and can’t find that there is a driver update through Apple.

I did uninstall and reinstall the version of Studio II previously had. I now am running Studio vs. 1.7.6 but it is now also terribly slow. It might take between 1 to 3 minutes to load and once loaded I get the spinning beach ball just about with every step. I really loved Studio as I use Texture Effects and Impressions a lot but I can’t go on like this.

I have been trying to read Topaz literature to see what if anything I can do. I Apparently my computer can’t do the “disable automatic graphics switching” thing.

My two questions (as I am not techie) Topaz literature says, “Reduce the size of your image or install hardware that meets or exceeds the performance of recommended hardware.”

  1. What is meant by reduce the size of your image?" I reach Studio from Lightroom, so do I have to reduce image size in photoshop (dimensions or pixels?) before sending?

  2. How do you get a new graphic card or can you? Do you have to buy a new computer?

I will submit a ticket with this information but I thought maybe somebody could answer these two basic questions for me here.

1 Like

Do you have this slowness when you use ONLY Topaz Studio (excluding Lightroom)?

If I understand your question it seems to be only when I want to take a
photo into Studio from Lightroom. This morning I went from Lightroom
directly into Impressions 2 and Speed was acceptable. Thanks.


Veda, thanks for this additional information! Just out of curiosity, did you use the exact same image to test application performance, when sending from Lightroom?

Joe, I didn’t use the same photo. I have tried with several different photos and Studio takes forever to open or stalls and won’t open at all. I just tried to launch Studio as a stand-alone, thinking if it worked, I could just drag my images in, but two tries and both time ending up having to force quit as it was responding.

I am having the same issue. All of sudden topaz is extremely slow. Whether I use it as a stand alone or via lightroom. I can’t use the program until this is resolved. Any suggestions?

1 Like

I’m having the same problem. I was going to buy the Pro Adjustment pack last night and decided to upgrade to the latest version of the software first and now it is so slow it is unusable. Glad I didn’t buy that Adjustment pack. So it appears this has been an issue for months. I was using Topaz Studio standalone. I’m on Windows 7. I had nothing else running at the time. I rebooted after install. I checked the CPU usage which was 13% and memory usage was 38%. This software should not be performing this slowly. Reducing file size is not an option for a professional. I have no performance issues with Lightroom, Photoshop or Luminar. Any resolution for this?