Topaz Studio Only Runs as Administrator

Topaz Studio has a bug where it will only run if it is started by an account that has administrator privileges (on a Mac, haven’t tried Win). I always do my day-to-day work with an account that does not have such elevated privileges (for security purposes). This bug was introduced back sometime around Aug/Sept. Prior to that it worked (after you hand copied files to the other account, since the SW/installer doesn’t seem to be able to handle the scenario of multiple accounts).

After submitting 2 separate bug reports I have made 0 progress getting this fixed. I received both auto-responses for the bug reports, but only a single email from a human being. I responded in great detail to that 1 email. No response. I can’t say with 100% certainty that they are not responding and that the emails are maybe getting caught by a spam filter, but I’ve looked in all the spam filter held messages I know about, and I see nothing. I have responded several times on the email thread, without any response. I see that the reply email addy is tied to the support number, so maybe they are closing the ticket and my email is dropped on the floor. But I’ve gotten no email stating that the ticket is being closed. I’ve tried the link to the support database for both tickets, several times, and gotten nothing but a generic database error page.

After waiting for weeks, I took an hour of my time and dug into the Topaz Studio .APP package and found the defect. It is a real bug, it is caused by their installer/package rather than my machine, it is easily repeatable by their SQA department, and has existed for 5 software updates. I hand fixed it. This is not the kind of research or fix that I would expect your average user without sys-admin skills to find or correct.

Any ideas how to get Topaz Labs to fix this (permanently, for everyone)? I’m trying this public forum to see if that gets something to happen. Else I’m stumped.

I LOVE their algorithms, but their software and user support is quite a “challenge” to deal with.

Hi David, Joe here. I’ve updated your request in response to your issue and addressing the delays you experienced with your support experience. Our apologies for taking so long to get back to you. We’re currently focused on answering as many people as possible in our support system, so you can expect to see a quicker response going forward.

Replied via email to orig support request. Sorry it took awhile, but too many 13 hr days at work recently.

There are several lib files in the .app package that only have “user” read permission, as opposed to a more correct “rw-r–r–” or “rwxr-xr-x”. Simple installer fix.

Ah, you found the cause! I was digging into the responses from the weekend and noticed that permissions were the most likely culprit based on the behavior I was witnessing. It definitely looks like a permission update from 700 to 755 on the Frameworks folder inside the Topaz Studio application package fixes the failure to launch. This will be a very quick fix for the development team to implement. Apologies for the frustration this issue has caused, but you have been the greatest help so far to determining the cause (as you did that yourself), and providing us with the steps you took to fix it.

Thanks again David. We’ll have this corrected in short order.

For clarity, anyone that comes across this post and has the same issue, here are the steps you need to take to fix the problem:

  1. Open Terminal
  2. Type: cd /Applications/Topaz\ Studio/Topaz\
  3. Press Enter/Return
  4. Type: sudo chmod -R 755 Frameworks
  5. Press Enter/Return
  6. That’s it!

Studio should now run correctly for you.

Is this the solution in Windows, as well?

No, not at all. Raise a support request as this is for Mac’s.