Topaz Studio file save is creating artifacts in saved image

I’m trying to use Topaz Studio to create an artistic look. I’m able to create the look I want but when I save it (doesn’t matter what file type) there are artifacts that have been introduced into the file. I’ve tried this as a plugin and standalone with the same results. It doesn’t matter what adjustments I use, the result is the same - artifacts are introduced. I’ve tried saving as a tiff, jpeg, png with various settings and the result is always the same - artifacts introduced.

I’m able to run AI Gigapixel and Jpeg to RAW AI without issues. A little slow, but no issues. I’ve also tested the file save from the standalone Topaz Impression 2 and there are no issues or artifacts. I just can’t get the look I want with the standalone version of Impression.

I’m using a Mac with the latest version of OS, 8GB Ram, 1TB Hard drive, Intel Iris Graphics Card with 1.5GB memory.

The first attachment is a screen shot (100% view) of how it looks within Topaz Studio, and the second is a screen shot of how it looks after saving the file (or returning to host application).

Anyone else see this or having a similar problem? I’ve submitted this to Tech Support ticket #165705 and haven’t received any response. As it stands, Studio is useless for me.


As you have raised a help request already, support should get back to you soon. You can reply to the confirmation email to add more information.

Also, if you are able when using as a standalone, include the save settings you use such as the Quality setting for JPEG. Also, if you can remember, the Adjustments you use from Impression.

It may be that the GPU is a little underpowered so, from one of the apps, just go to Help-> Graphics Info, then click Copy and paste the information here.

While you are waiting for a response use the Impression 2 plugin or standalone.

Hey Don, thanks for the reply!

Not sure how including the file save settings would help as I already stated that it doesn’t seem to matter what the settings are, the artifacts are still there. I’ve tried them all - low to high quality jpeg, tiff with no compression to tiff with compression - it does not matter. It also doesn’t matter what file type is chosen - jpeg, tiff, png, etc… I do wonder if maybe there was a “glitch” in the update for Studio that might be causing this? I think I will do a complete reinstall and see if that makes any difference. If not, I will provide file settings to see if others might have other possible ideas.

If my GPU is a little underpowered (which it probably is), wouldn’t I see issues or problems with the real power hungry applications of AI Gigapixel and Jpeg to Raw?? I have no issues with these applications other than being slow. Topaz Studio also runs with out problems (both as standalone and as a plugin) until I save the file. There is no indication of a problem until you zoom in on the saved file.

Also, I already stated that I cannot get the look I’m after in the standalone version of Impression. I need the blending of Impression and AIRemix to get the look I want.

My point for posting was to see if anyone else is having a similar issue and if so what they did to resolve the problem. I’m still waiting on a reply from support, and have already provided additional information previous to my posting here.

1 Like

Clean install did not fix the problem. I’ve sent detailed information to Topaz on the support ticket.


Was there any update to this? I’ve created a support ticket today for exactly the same issue. Whether using Topaz Studio via Lightroom, or standalone, this issue seems to be apparent whenever I save an image.

1 Like

Sadly no, there has been no response at all. There was a recent update to Studio, but it did not fix the issue. It feels as though this is being treated as a none issue.

1 Like

Looks like it’s fixed as of the latest update a few days ago.

1 Like

Hello … I am having the same issue as you have - and I have a Mac.
It is now 2020 March … did you really see a fix in this issue?

I dont know what to do …

I am having this exact same issue with Topaz 2 … either as a standalone, or as a plugin within photoshop; I also operate from a mac …

Is there a solution to this issue ?

Application & Version: Topaz Studio 2 Version 2.3.1

Operating System: macOS High Sierra (10.13)

Graphics Hardware: NVIDIA GeForce GT 750M OpenGL Engine

OpenGL Driver: 4.1 NVIDIA-10.32.0 355.

CPU RAM: 16384 MB

Video RAM: 2047 MB Total, 2047 MB In Use

Preview Limit: 4492 Pixels

I upgraded my Mac to the 2019 iMac and have 64GB of memory. I don’t see the issue with this environment. Previous I had a Mac Mini with 8GB of memory. After the update of the software, I didn’t see the issue unless I was pixel peeping at 200% or more. The problem was still there, but not as visible. As far as I know, the problem still exists, I’m just not seeing it because of my hardware upgrade.

Hi All,

This issue was fixed with Mac’s release of OS 10.15. If you update your operating system this issue should resolve.

1 Like

Thank you so much Emily for you quick reply.

I have never changed operating system on my Mac - so you are suggesting - totally upgrade from macOS HighSierra (the latest), to macOS Catalina 10.15.3?

1 Like

Upgrading to Mac Catalina 10.15 plus did not work …
Looking forward to your reply
See attached image - artifacts … and mac OS system upgrade
… this post doesnt appear to allow me to attach an image …

the same artifacts still exist …

Seems like the same problem I had with Topaz Studio, on Windows (so can’t be Mac OS-version related):

The problem didn’t arise when my images where small enough (I was trying it on +/- 24 megapixel images with these issues… but sizing down to 12megapixel or 8 megapixel and the files were fine).

The problem also only appeared on my machine with an Intel HD integrated graphics, not on my other machine with dedicated nvidia graphics.

I mostly use (used) Topaz Studio for AI Clear. But I noticed the same issues with other adjustments.
Also, Denoise AI with the ‘AI Clear’ model runs just fine, even on big images… so it seems to be a proble in Topaz Studio.

Since they moved to Topaz Studio 2 and are not supported v1 anymore, I don’t think the problem has been fixed. And since I can’t seem to download Topaz Studio v1 anymore (the link from my account page for downloading goes to the Topaz Studio v2 site) I can’t check anyway.

and since support couldn’t fix the problem, they refunded my purchase. I told them I still wanted the product, so they let me keep it while refunding it.

Although very nice, that leaves me with no support for a product that went ‘legacy’ a short time after and with no upgrade-path for me except to buy the whole of Topaz Studio for full-price again.

I’m not really allowed to whine about it since I got the AI Clear adjustment for free in the end, but I would rather have paid for it and have it working like it was supposed to… on the other hand, I’m glad I didn’t end up paying for AI Clear adjustment only to have it be abandoned without an upgrade path a few months later.

The Downloads page on Topaz Labs main website is where you download from, for legacy items such as Studio 1 download from the Legacy Downlo0ads from that page.

Take a 30 day trial of Studio 2, but make sure you meet the system requirements at:

I recently used Topaz Studio 2 and had this same issue. It looks fine, then when you save/export it… artifacts. Any resolution yet? I’m running on an iMac Pro, macOS BigSur 11.2.3

Really frustrating.