Topaz Studio 2 - filters not available

Updated Topaz Studio 2 and now Impression, AIRemix and Texture filters don’t appear to be functioning

1 Like

I don’t recall if you’re on a Mac… I just tried on a Win 10 box and they seem to work correctly.

Studio 2 v2.02

I am sure a version number and a platform (Win/Mac) would be helpful. v 2.0.2?

Same here. Checked mine out and all seem good. WIN 10

Version 2.0.2 … WIN 10

1 Like

Interesting issue. I tried stand alone on a JPG and a TIF, both fine. Then called Studio 2 from LR, also fine. :thinking:

Curious to see what’s causing it not to work for you. And also what you’re going to do with the pretty rose. :grinning:

Hi Sharon, It doesn’t seem to be a GPU issue as I tried it on both Intel & NVIDIA. Try rebooting your PC and if it doesn’t work after that then raise a support request.

Odd…appears to be working ok on AMD, too, afaik.


@ScottO … not exactly sure what was going to be the outcome for the roses … that’s the fun of Studio :slight_smile:

1 Like

good news all … after uninstalling and reinstalling I can once again use Impression, Texture and AIRemix … yay


Very strange. Keep an eye on it. Let us know if it happens again.

will do