Topaz Studio 2.0.9 (commerc. vers). Wiped Out Studio 1 Plugin Access

There is a bug in the just-released TS 2.0.9. It wipes out Studio 1 from appearing in the Ps CC 2019 “Filters” Menu under Topaz Studio. See snip below.

I only use the Studio products #1 & #2 as plugins to Ps CC (on my Win 7 64-bit PC) as part of my Ps workflow.

How do I get that re-enabled quickly for use with near-term projects?

I never saw a listing for Studio 1 in that menu list since Studio 2 was rolled out (beta - as reported - and commercial). But, at least there were a few residual filters from TS 1 that had remained in that filters menu list along with TS 2 that provided me a ‘back door’ to get into Studio 1.

Now there is nothing. That is a serious issue. The products work in different ways and I paid for TS 1 and I would like access to it as an alternative when desired in Ps CC; even if the functionality ultimately gets ported to TS 2 (which it is not now). I do not/will not work with standalone products then hop into Ps. It would be inefficient and undoable for how I process images.

Thx in advance for a quick fix to that!

Snip of Ps CC 2019 Filter Menu (plugin BUG that wiped out plugin access to TS 1):

@Fotomaker I have TS 2.0.9 installed and still have access to both in PS CC (Win 10)

Can you do a restore?

1 Like

Oh man!

So, until this 2.0.9 vers. I saw all the same filters you show in your snip (Clarity, Detail, Glow, Impression, Simplify, Texture Effects) but no listing for Topaz Studio.

If I clicked on one of those filters it, at least, took me into Studio 1 in a not very direct way. But I could at least get in and work with it.

Something in the latest revised code wiped out all the other listings that were there.

My suspicion is they need to correct for those of us running Win 7 PCs. We can’t be w/out Studio “classic” if we paid for it and need to use it as a plugin.

They had to do some jiggering re: processing approaches on some of the AI products for my system too… But it has ended up helping a lot of other users who found that if they went to the lower memory utilization options the programs didn’t crash for them either. This may be another case of somebody overlooked the Win 7 PC user population and it needs to be corrected…

Thx for writing in b/c it helps narrow what the bug/faulty code could relate to!!

Per your question: I did all the usual rebooting and re-launching Studio 1 as standalone, etc. that usually in the past would have helped activate it in Ps CC… Sigh.

1 Like

Have you tried to run Studio 1 as a standalone? That is the way to get it into PS as a plugin.

Yes. That was the 1st thing I tried when I saw the issue… based on experience from the past. It didn’t help. But thanks for suggesting.

As I told Linda above, not only is “Studio” not showing up in the Ps Filters menu but neither are any of the other TS 1 adjustments that used to be under that heading and that served as a klugey way for me to still get into Studio (w/out the straightforward heading to click on).

I opened a trouble tkt about it too…

Well the next thing to do is do it yourself because it looks as though it has been removed:

Procedure is … and replace DiskID with the local disk identifier where you program files are, e.g. C or D etc:

  • Go to DiskID:\Program Files\Topaz Labs\Topaz Studio
  • Right Click on the PS_Plugins_x64 folder
  • Click Send to> and choose Desktop (create shortcut)
  • Right click on the shortcut created and rename to topazstudio1ps_x64 or whatever you like
  • Right click on the renamed shortcut, select Properties, and enter the following, with the quotes, in the Start in: field “DiskID:\Program Files\Topaz Labs\Topaz Studio”
  • Click OK

Then move the Shortcut to DiskID:\Program Files\Adobe\Adobe Photoshop CS6 (64 Bit)\Plug-ins and your good to go.

MAKE SURE: DiskID has been replaced with the correct disk identifer in every place.

1 Like

So do you mean just on my machine it’s been removed (which I don’t know why that would be) or for everyone?

B/c if you look at the snip Linda Greene (sp?) posted above her system is still showing all the adjustments and Studio 1 there.

During the beta testing for Studio 2 my “Studio” notation disappeared from my Ps CC Filters menu (it had been there previously). But what was left was the other adjustments/filters that Linda is showing in her snip above. Now those are gone too.

For your recommended step 3 above (with the Send to instruction) I’m kinda nervous about that b/c I have a ton of 3rd party plugins and I don’t want anything screwy to happen to all of them (not to mention all my “classic” multiple generations of Topaz products that I don’t want to lose b/c at this point they’d be unrecoverable. I’d be completely shut down. It sort of sounds like you’re saying I should re-name my entire Ps plugins folder to topazstudio… Did I misunderstand?

No, read the instructions I said Send to> then Desktop (create shortcut) not rename any folders.

The process works, I did it on my PC, but follow it to the letter.

okey dokey.

my life just flashed b4 my eyes at the thought of losing plugins. especially after losing hundreds of dollars of unrecoverable on1 filters when i migrated to a new pc last yr and their authorization service was kaput and couldn’t re-verify me.

oh yeah and one more question… what’s to stop future releases of TS 2 from knocking out the stuff you’re telling me how to re-populate?

The name I chose won’t be deleted as it is not one Topaz Installers would use and, even if they add it back in again under another link name it won’t be duplicated in PS.

okay… :crossed_fingers:

1 Like

OMG! It worked!!!

You have just added years back onto my life!

Thank you! Haven’t had PoS (Plain Old Studio) in the Ps CC 2019 Filters menu since started working with TS 2. But at least had had the other related TS 1 adjustments/filters. Now it is all back.

What does Staples say as a marketing slogan, “Well, that was easy!”