Topaz stopped working

The programm just freezes, it was working fine after I paid and downloaded it today and now it already stopped working, it froze, I tried restarting and it just doesn’t work. Please help!

Please make a clean uninstall, downlaod the latest version and make a fresh install:

Hi, Imo, I did a clean uninstall and reinstall and still get the same. All the buttons are either unresponsive or the whole program just freezes. I am so sad as I love your program! What else can I try? I am on Mac Ventura 13.5.1 (22G90).

If it isn’t working I am afraid I will have to ask for a refund as that is a lot of money for something that worked once and not again. :(((

Greta

Hello Greta, please write to help@topazlabs.com
The Topaz team normally responds quickly. :slight_smile:

Please follow the instructions below to perform a clean install to better troubleshoot why you had this problem with Topaz Photo AI:

Start by clearing any previous plist files that are on your computer for Topaz Photo AI by following the steps in the link below:

Topaz Photo AI | plist Files Mac

After you have done this, disable any antivirus, firewall, VPN, or proxy software that might be active on your computer. These tools are sometimes known to interfere with the installer’s ability to download the model files.

Please also ensure that the Topaz Photo AI installer has all the proper settings in your system by going to your Mac System Settings > Privacy & Security tab and scrolling down to the security section. You will want to make sure you have 'App Store and identified developers ’ selected. Here is a video example:

Example of Proper System Preferences

Finally, rerun the installer. You can download a new installer from the downloads page directly :

Topaz Labs Download Page

If you are still experiencing problems after following these steps please reach out to us at the following link:

Topaz Labs | Support Page

Are you guys kidding about those instructions? The product was purchased and the expectation is that it works. I don’t have the time … nor should a normal consumer … have the time to run through a detailed list of instructions that may or may not be easily accomplished. The program has ceased to be operational on my MacBook Pro with an M1 chip. It freezes within photos when using the editing function. The drag and drop just doesn’t work period. What’s the story, folks? I love the program but am extremely disappointed right now that there is not a simple solution.

Please follow the instructions below to fix this issue:

Topaz Photo AI Freezes on Importing Image (Mac)

This topic was automatically closed after 49 days. New replies are no longer allowed.