Topaz Sharpen 3.0 crashes

I tried it, but it crashed out several times I tried a different photo which I tried to save before it crashed again, but now my original photo has a new time stamp and artifacts, not very impressed. I have now uninstalled it and have gone back to Version 2.2.2

Please please PLEASE tell me how to go back to previous version. Link to old version? Some other way. As soon as I uploaded the 3.0 upgrade and tried to run it…the software was bricked; non-functional.

2 Likes

Please supply information on your OS, RAM, GPU/vRAM and driver version.

What type of image are you processing and how do you invoke DeNoise?

You need to provide some basic information like I asked in the post above.

Product release section provides downloads of all previous versions of all software:

https://community.topazlabs.com/c/releases

1 Like

A post was merged into an existing topic: Sharpen AI v3.0

Hi Don,
Windows 10 Pro 64-bit, 16Gb RAM, Nvidia GT 610 Driver 391.35. I used Sharpen as stand alone.
My biggest worry is why it changed my origial file a .jpg file.The previous version was great.
Clive

I updated it today but crashed several times on my mac. I restarted my mac two times but it didn’t held. How i am going back to the old version?

Make sure CPU processing is selected in Performance section of the Preferences as the GT610 isn’t supported.

The Product Release section on this Forum will have the previous versions available in the first post in the thread. Select from the Category drop down.

Is that why it it changed my original file ?

No, you were probably using in plug-in mode. Plug-in mode is where you use edit with etc., from Finder/Explorer or another application. Open your images from within the app and you will then get the save as dialog.

So if I drag and drop a file onto the AISharpen icon that puts it in plug-in mode ? I dont understand why there would not always be a save as dialog, I am sure I did the same with the previous version and it saved the changes in a different file.

That action has always opened in plug-in mode. But you can drag an image onto the open application to get around the plug-in mode.

OK, I will have to try to remember that, thanks

Both my iMac (2010) and Macbook Pro (2013) won’t open the software after I installed the Sharpen AI 3.0 update. And now I can’t reinstall the older version despite getting links to 2.2.4. About to abandon Topaz Labs at this point.

Why can’t you install the previous version after removing v3?

The downloads are on this forum in the Product Release section.

Uninstalled 3.0 and then used the 2.2.4 reinstall links provided here - 4 times, but without success. Right now Sharpen AI is dead in the water on both computers.

Sounds like there is an issue on your PC’s if it ran before. Raise a support request at the main website as they can examine your PC.

There isn’t enough information about the issue you are facing as, usually, you will get an error message if you cannot install or start there application.