Topaz Photo AI v1.3.7 - Recover Faces Red Color Added in Recovery

Applying Topaz AI v1.3.7 to auto racing image. Process included Recover Faces. Driver is wearing a helmet. When applying Recover Faces there is a red tint around the driver’s face in the edit preview window. I’ve had this occur on two different images in a row.

Steps to reproduce issue:

  1. Opened image in Photoshop Camera RAW, made some adjustments and then opened image in Photoshop.
  2. Ran Topaz Photo AI with automatic detection settings. Filter selected driver’s face for recovery.
  3. Preview window shows obvious red tint around driver’s face next to helmet.


Screen capture of preview editing window.


Topaz Photo AI v1.3 on Windows

Adding red tint to faces is racial biasing and should be removed from the application, it should preserve the color of the source. Let someone recolor in photoshop if they want to do that.

This is not specific to .raw, and is a ‘feature’ of faceai that also happens with .tga, .png, .jpg…nor is this a new ‘feature’ of 1.3.7 as prior releases also do this.

I have processed many dozens of faces and they all have red bias pushed (even green orcs and blue elves!)

It is not just skin color, eye/lip colors are also color biased not preserving the source color.

Thanks for reaching out. Please send the following information so I can try to reproduce this.

  1. The original image file.
  2. The processed image.

You can securely submit your image(s) to my Dropbox using the link below. Please be sure to send me a note to let me know you sent something.
Dropbox File Request

This red tint is an artifact. It appears on black and white images as well. We will be updating the Recover Faces AI model to handle this and details such as eyes better next quarter.

Is there any update to this thread or a solution. Processing in Raw is not usable at all. Thanks

Do you have an image example where this is an issue? We had added a potential fix previously, if it’s still happening I can let my team know.

Please send the file and steps to reproduce the issue.

You can securely submit your image(s) to my Dropbox using the link below. Please be sure to send me a note to let me know you sent something.
Dropbox File Request

I’ll will have to see if I can recreate this issue. It occurred two months ago and I did not save a copy of the poorly tinted face image at that time. I’ve been staying current with all of the Photo AI updates, so I don’t know if this will occur on a new attempt.

Hopefully it does not has we had tried to resolve it previously. Let me know if it happens again.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.