Topaz Photo AI v 2.3.2

I’ve been using Topaz Photo AI for some time with great success. I use it with my Apple Mac photo-editing software and press the 'three dots ’ to invoke Topaz from Apple editing. A couple of days ago everything ground to a halt and I can no longer use it. Loading photos is extremely slow and I can no longer edit them.

I’ve tried look at CPU/GPU in preferences / general but the software does not respond. I’ve also tried reloading Topaz Photo AI but have there same issue.

Any suggestions?

Steps to reproduce issue:

  1. Step 1
  2. Step 2
  3. Step 3

Topaz Photo AI [v1.x.x] on [Windows/Mac]

Please follow the instructions below to perform a clean install to better troubleshoot why you had this problem with Topaz Photo AI:

Start by clearing any previous plist files that are on your computer for Topaz Photo AI by following the steps in the link below:

Topaz Photo AI | plist Files Mac

After you have done this, disable any antivirus, firewall, VPN, or proxy software that might be active on your computer. These tools are sometimes known to interfere with the installer’s ability to download the model files.

Please also ensure that the Topaz Photo AI installer has all the proper settings in your system by going to your Mac System Settings > Privacy & Security tab and scrolling down to the security section. You will want to make sure you have 'App Store and identified developers ’ selected. Here is a video example:

Example of Proper System Preferences

Finally, rerun the installer. You can download a new installer from the downloads page directly :

Topaz Labs Download Page

Let me know how that goes for you and I’ll keep an eye out for your reply.