Topaz Photo AI keeps crashing

cannot use the program after buying the latest version 2.4.2 for Windows … keeps crashing when trying to load image and process it. I have tried multiple times in a row with the same results … it just doesn’t work.

Steps to reproduce issue:

  1. Step 1
  2. Step 2
  3. Step 3

Topaz Photo AI [v1.x.x] on [Windows/Mac]

Same thing is happening to me. It will open jpegs but anytime I try to open a raw image it will crash. Photos are shot on a A7r5

I’d like to get some more information to help troubleshoot the problem you are having.

Could you send us your computer’s full system profile?

Also if you can, please try to recreate this crash in Topaz Photo AI, then go to Help > Open Log Folder, please send me all of the files within that folder. You should be able to attach them directly as a response to this email.

You can securely submit your files(s) to my Dropbox using the link below. Please be sure to send me a note to let me know you sent something.

Dropbox File Request

Hello - - I just sent the system profile via the dropbox file request link.

hello again - here are the log files

Filter Plugin Log.txt (4.97 KB)

2024-04-12-19-54-41.tzlog (28.9 KB)

2024-04-10-06-40-59.tzlog (28.7 KB)

2024-04-10-06-37-8.tzlog (29.5 KB)

2024-04-10-06-36-33.tzlog (28.7 KB)

2024-04-10-06-40-49.tzlog (28.5 KB)

2024-04-12-19-55-19.tzlog (20.9 KB)

lastSessionFiles.txt (78 Bytes)

2024-04-10-06-24-31.tzlog (29 KB)

2024-04-10-06-26-24.tzlog (28.7 KB)

2024-04-10-06-25-46.tzlog (68.8 KB)

2024-04-10-06-26-36.tzlog (28.6 KB)

2024-04-10-06-26-46.tzlog (69.8 KB)

Topaz Photo AI Installer Log.txt (4.64 MB)

I had gone back to some earlier versions of Topaz PHoto Ai, and it seemed to work fine.
My computer is 8 years old.
I just ordered a new one, but it will be a while before I have it up and running. Meanwhile I was hoping this would work if I got the latest version, and apparently it will not.
Thanks for reviewing the information and your time.

1 Like

Still unable to use Topaz Photo Ai. Just tried to go back to earlier version and nothing.

Hi - I just sent the dxdiag file off my new computer, and still cannot get the programs to work.