Topaz photo ai **allocates memory but does not release it !** until crash on macos

I use a mac M2 and i try to batch process canon raw files . sometimes i can process 180 files before crash and some times only 15 or just 10 before crash . I started to investigate and i found the reason : topaz photo ai allocates memory but does not release it ! the memory allocation is accumulated until crash .

Steps to reproduce issue:

  1. Step 1 - open topaz photo ai in stand alone mode and open activity monitor - write down how much memory topaz consumes in this idle state ( few Mb only )
  2. Step 2 - open lets say 100 raw raw files and do nothing - write down how much memory topaz is using now … lets say 5Gb …
  3. Step 3 - close all open pictures and clear all recent files - we are now again were we began . idle state , no file loaded files , no recent files - topaz is not doing anything - THE MEOMORY WAS NOT CLEARD ! topaz continues to hold the 5GB …
    4.step 4 - open again 100 raw files - check memory , it did not used the 5G already allocated ! check the activity monitor and you will see that now topaz is using 10GB …

topaz will accumulate the memory until all physical and swap memory will consumed and then will crash .

in bach mode - every file processed increase the memory allocation until all physical memory and swap are consumed and will crash .


Topaz Photo AI [v3.0.2] on [Mac M2]
I sent crash logs when it crashed .

I see on this thread you said you sent the log files however have not been able to locate these files.

I’d also like to get some more information to help troubleshoot the problem you are having.

Could you send us your computer’s full system profile?

Would you mind sending those in to the following link:

Dropbox File Request

Make sure to send me a note to let me know you sent something. :slight_smile:

hello John ,

Thank you ,
I uploaded the crash log , screen shoots until crash and full system profile as per your request .
hope problem will solved .

regards,
Amir

Thanks for sending in that information. I’d like to see if a clean install would resolve this problem you are having while using Topaz Photo AI.

Start by clearing any previous plist files that are on your computer for Topaz Photo AI by following the steps in the link below:

Topaz Photo AI | plist Files Mac

After you have done this, disable any antivirus, firewall, VPN, or proxy software that might be active on your computer. These tools are sometimes known to interfere with the installer’s ability to download the model files.

Please also ensure that the Topaz Photo AI installer has all the proper settings in your system by going to your Mac System Settings > Privacy & Security tab and scrolling down to the security section. You will want to make sure you have 'App Store and identified developers ’ selected. Here is a video example:

Example of Proper System Preferences

Finally, rerun the installer. You can download a new installer from the downloads page directly :

Topaz Labs Download Page

Let me know how that goes for you and I’ll keep an eye out for your reply.

Hi ,
thanks for quick reply, i will do and check again and i will report back .

BR
Amir

Hi ,
I did all the steps and instructions in your mail and I restarted the computer .

  1. when I start topaz it uses few M only (202.8B)

  1. then I load some raw images (192 ) and I do ABSOLUTELY NOTING (the only thing that happened is that the auto pilot processed the 1st image )
    topaz is using now 5.03 GB

  2. now i “select all” , RMB and “close all images” in addition i CLEAR Recent . Topaz is now at the same state as after invoking NO FILE IS LOADED and No recent files , BUT topaz is still holding all memory , memory was not cleared - this is a server bug imo - no other software on my mac behaves as this . This bug severely hurts my workflow , I don’t know when topaz will crash and all my edits will be lost .

I really appreciate your support and hope this issue will resolve soon .

BR

Amir