Topaz Photo AI 2.0 hangs on opening an image

Hello all, I noticed this issue occasionally happening after the last update, but since updating to 2.0 today the issue happens (for me) in every instance.

Photo AI 2.0 will launch fine. When you open or drag and drop an image to open the program will hang, sometimes spinning wheel, sometimes not, until you eventually check the icon in the dock and see Application Not Responding, requiring a Force Quit. The same issue will occur when launching the plugin in Photoshop CC

I moved the Photo AI application to the trash and downloaded a new installation, installed it and am having the same issue.

Is there something I am overlooking? Any suggestions are welcome.

Many thanks.

MBP 16" 2021
M1 64GB
OS Venture 13.4.1 (22F82)

Steps to reproduce issue:

  1. Launch Photo AI 2.0
  2. File>Open Images
  3. Hang until Force Quit required

Topaz Photo AI [v2.0] on [Mac]

Looking around I came across the suggestion to delete the .plist files and reboot, from an earlier version. I tried this and it seems to have worked for me.

I’m glad to hear you were able to find the solution! Please reach out if you need help with anything else.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.