Topaz Photo AI 2.0.1 fails to start from Lightroom Classic (MacOS)

I know that this was an issue with version 1, but it is occurring again with Version 2.

When I try to export from Lightroom Classic 12.5 (using File > Plug-in Extras > Process with Topaz Photo AI - Edit a Copy), I get the following error message:
Topaz Photo AI either failed to start or did not finish successfully. Exit code: 32512

Mac Studio System Report.spx (8.9 MB)

2023-09-19-12-47-13.tzlog (12.7 KB)

@jswt2525 It looks like you also submitted a support ticket about the same conflict. Did resetting the Lightroom plugin fix this for you?

Hi Tim,
Exiting LR and re-installing Photo AI 2.0.1 has not resolved this problem……

It looks like you are using a virtual copy of an image instead of the actual image.

Please select the DNG file directly instead of the copy and process that.

Unfortunately the error persists when I use File > Plug-in Extras > Process with Topaz Photo AI - Edit a Copy with the original DNG file.

Is the original DNG file located on your computer?

Could you send me the file so I can try to reproduce this issue?

You can securely submit your image(s) to my Dropbox using the link below. Please be sure to send me a note to let me know you sent something.
Dropbox File Request

Hi Lingyu,
I could do that, but please be aware that I have tried the export process with a number of different image files - both DNG and TIFF - and the same problem always occurs……

I should add that my image files are all held on an external drive, only the LR catalog is on my Mac Studio M1 internal SSD.

Odd. Could you try moving a file to your desktop and importing it to LrC then processing it?

I’m curious if the location affects the processing.

Does the external drive have additional security? You may want to give Topaz Photo AI and Lightroom Classic full disk access in the System Settings > Privacy and Security tab and see if that changes the behavior.

Still getting the error from a desktop-based file (see screenshot).
The Apps have full disk access to the external drive.
My other Topaz apps (eg Sharpen AI) have no problem with this setup……

The file name is different for the image on your desktop and the image in your Lightroom catalog.

Please make sure you are processing the exact image that is on your desktop (55da4.tiff).

Hi Lingyu,
It IS the same file - the name gets a prefix upon import….
If I disable the import renaming (i.e. exactly the same file name), I still get the error….

I see, thanks for letting me know.

Is Topaz Photo AI running when you use it in stand alone?

We may need a screenshare to figure out what is happening here.

Photo AI runs fine as a standalone app.
One thought - could it be something to do with the fact that in my set-up Photo AI sits in a “Photography Apps” sub-folder within my Mac’s Applications folder?

That was the problem!
I have moved Photo AI into the ’top-level’ Applications folder and all is well.
I know many users who have Applications sub-folders, so maybe this is something to consider for the future?

Great news, I’m glad to hear you were able to find the issue.

At the moment the path for the plugins is coded to the location in the Applications folder so moving it will break the plugin.

Please let me know if I can help with anything else!

Thank for your patience Lingyu!
One thought/observation……
When you access Photo AI via Lightroom, it returns the processed image to LR with the same file name.
It would be great if in a future update the Photo AI-processed image could have the applied filters appended to the end of the returned file name (as happens when you se Photo AI as a standalone app e.g. 5541A5.tiff becomes 5541A5-tpzPhotoAI-enhance-1.8x-faceai-sharpen.tiff).
Have a great weekend!

I’ll check if this is possible. The plugins do not have export settings like the stand alone does as it has to play nice with how Lightroom Classic wants to handle the file.

I made a task for my team to look into a feature like this in the near future.