Topaz Photo AI 1.5.3 crashes

Hi, Support ,

I was running Topaz Photo Ai 1.5.2 quite happily, went on vacation in August, came back, notice version KB5029351 for windows 11 22H2 was available, so installed it, also noticed there were TPAI new versions 1.5.3 and 1.5.4, so installed them as well.

Now Topaz no longer works, either as standalone or as plugin from Capture One. From either mode, I get “loading image”, “scanning image subject”, then “scanning image detect” then it “crashes”, that is it just disappears from the screen, saying nothing.

I then tried “repair”, uninstall re-install, but no go. Though It must be a problem with 1.5.4, so I uninstalled it and installed 1.5.3, same problem.

Thought it might be Windows, but I was reluctant to restore it, so I used Windows to uninstall Topaz entirely, then installed 1.5.0, that works fine.

Installed 1.5.1 the same way, works fine.

Installed 1.5.2 the same way, works fine.

Installed 1.5.3 the same way, no longer works.

I have fallen back to 1.5.2, used it for a few days, and it works as expected. I guess the problem is within Topaz.

Happy to help if you need it.



Steps to reproduce issue:

  1. Step 1: Just install 1.5.3 or 1.5.4

2023-09-04-15-52-49.tzlog (29.4 KB)

DxDiag.txt (141.7 KB)

Topaz Photo AI v1.5.3 or 1.5.4 on Windows 11 22H2 KB5029351

Thanks for reaching out. Please reproduce this issue by updating to v1.5.3 or v1.5.4. When the application crashes after importing an image, reopen Topaz Photo AI.

Go to the menu bar on the top and click the Help > Open Log Folder menu option. Attach the bottom 3 logs files that you can see in the window that opens here so I can review the contents.

I should be able to determine what is happening and send next steps with this information.

Hi, Lingyu,

Thanks for a prompt reply.

Since I was running 1.5.2 quite happily, I decided to use the “internal” update within Topaz to go to 1.5.4. I then selected a random picture to report the crash…but it worked !

Since I normally send a few images from Capture One Pro to Topaz, I selected a few, and that worked too.

So, I decided to go back to exactly what I had been doing when I crashed, and this time it DID crash. I was sending 23 pictures from Capture One , so decided to bypass Capture one, but it still would not work in standalone Topaz.

So, it tried a couple from Capture One, and the same from Topaz standalone, and that worked.

So, I thought it must be one specific picture, then tried every single picture one at a time, and found the “failing” one.

I was very unlucky, for it was the first one, which was always included in my trying to find if the problem was the number of pictures in cause.

Anyway, my process is to use Capture One to adjust the Nikon raw images, and if required, color tag them “Topaz”, so I can send them all in one go as .tif to Topaz for adjusting.

I did try with a .jpeg and a .dng for that image as well, but it does not work either.

I don’t understand why 1.5.0 to 1.5.2 work OK with that image, though.

I have included within the mail the required log information (standalone Topaz) as well as the .NEF file.

Hope that’s sufficient for you to recreate the problem.



2023-09-06-17-51-35.tzlog (29.4 KB)

2023-09-06-17-51-52.tzlog (30.7 KB)

Topaz Photo AI Installer Log.txt (1.57 MB)

_PTL0002.nef (10.5 MB)

Thanks for sending the file. I see the error and shared this with my team so we can look into a fix.

Hi, Lingyu,

Just to let you know that my update plan entitles me to download Topaz AI v 2, which I have just done, and my problem has disappeared !

I have tested about a hundred pictures, everything is fine.

Don’t know what you want to do with this, but I happy to help if required.



That’s wonderful news, I’m glad that the update fixed the issue.

Please let me know if I can help with anything else!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.