Topaz Mask AI Update Nag Screen?

Is there any way to disable the nag screen every time I open Mask AI (v1.2.4)? I have a document that I have to mask over 50 layers on. Every time I open AI it pops up a screen saying there is an update. It may seem like as little thing, but it is getting frustrating. I know there is an update and I cannot update to it right now.

Please help!

I haven’t tried this but it might disable if you disconnect from the internet.

Thanks Artisan-West. I am really hoping there is a better alternative than that since I use the Internet a lot as I am working. I appreciate your suggestion and may need to try it…

We have asked for a preference option to disable the update nag quite some time ago …to no avail.

I finally got one of the Topaz programs wanting to update so I ran a test. I’m using Windows 10 but there may be a similar function on Macs. To stop the update nag, I simply clicked the WiFi radio symbol on the right side of the task bar. One of the options is Airplane mode. Click that to turn on and it will disconnect from the internet. and stop the update nag. It actually leaves the connection to the wifi active so if you are finished withe the Topaz app and close it you can simply click on the airplane symbol and turn off the airplane mode. You are instantly reconnected to the internet.

Nice work Artisan-West!!! I am on windows, but your trick worked. I decided to take it a step further. I created a Windows Firewall rule that blocks outbound connections for the MaskAI autoupdate.exe. It worked and now I can keep my main network on and no nag screens. YAY! Productivity restored! If I want to run the update at a later date I can just disable the firewall rule.

2 Likes