Topaz Labs Photo AI unresponsive and freezing

Try to include logs (Help → Logging) - not present in current version its help open log folder
2024-03-28-17-36-4.tzlog (176.6 KB)
2024-03-28-17-37-40.tzlog (81.2 KB)
2024-03-28-17-40-22.tzlog (874.7 KB)
2024-03-29-09-57-36.tzlog (116.5 KB)
2024-03-29-10-01-7.tzlog (240.1 KB)

Steps to reproduce issue:

  1. with Lightroom open and then I click on edit with Topaz Photo AI in the Edit with Dropdown menu when right clicking on an image in Lightroom, then selecting make a copy with Lightroom adjustments then clicked on edit. (file type is tiff uncompressed in prophoto colorspace(
  2. wait for topaz to finish the autopilot (once topaz photo ai is open the freezing of the view pane and unresponsiveness is already started)
  3. wait for generating preview to finish (Takes an abnormally long time)
  4. near complete unresponsiveness

Topaz Photo AI [v2.4.2] on [Mac with Apple Silicon M1 Max]
2024-03-29-19-15-37.tzlog (255.1 KB)
2024-03-29-20-19-17.tzlog (99.6 KB)
2024-03-30-11-15-3.tzlog (128.3 KB)
2024-03-30-11-20-38.tzlog (25.9 KB)
2024-03-30-11-27-13.tzlog (99.9 KB)
2024-03-30-11-35-45.tzlog (138.8 KB)
Filter Plugin Log.txt (4.3 KB)
lastSessionFiles.txt (69 Bytes)

Please follow the instructions below to perform a clean install to better troubleshoot why you had this problem with Topaz Photo AI:

First make sure that you have Lightroom and other plugins fully closed before proceeding.

Start by clearing any previous plist files that are on your computer for Topaz Photo AI by following the steps in the link below:

Topaz Photo AI | plist Files Mac

After you have done this, disable any antivirus, firewall, VPN, or proxy software that might be active on your computer. These tools are sometimes known to interfere with the installer’s ability to download the model files.

Please also ensure that the Topaz Photo AI installer has all the proper settings in your system by going to your Mac System Settings > Privacy & Security tab and scrolling down to the security section. You will want to make sure you have 'App Store and identified developers ’ selected. Here is a video example:

Example of Proper System Preferences

Finally, rerun the installer. You can download a new installer from the downloads page directly :

Topaz Labs Download Page

Let me know how that goes for you and I’ll keep an eye out for your reply.

This topic was automatically closed after 60 days. New replies are no longer allowed.