Topaz Gigapixel AI doesn't produce any output

I don’t know if this has already been posted elsewhere, but I’m running the current version of Gigapixel (3.1.1) on a Windows 10 machine. For the past half an hour, I’ve been trying to scale up an image and export it. However, even though the program keeps claiming the export has completed, the output is nowhere to be found on my system.

Does anybody know how I can fix this issue?

Thanks in advance for help.

Open Gigapixel and check Output > Save To>
You should see where your file is. I have noticed in Win 10 that the file doesn’t always show up right away, I have also seen this with other apps as well.

@Ricci, I’ve always checked that section of the interface. There’s no file, regardless of what folder I choose. I’ve changed it to three folders now, and nothing appears. It’s been a hour since I first tried. I’ve also tried the ‘View output’ pop-out icon that’s on the left of the panel showing details of the file to be exported, but nothing ever pops up.

I should also add that when I attempt re-exporting, Gigapixel closes itself down.

I’ve also tried changing the compatibility settings as a troubleshooting measure, but the same problem(s) remain.

The only thing left is to uninstall and reinstall, and see if it makes a difference.

What file extension is it, and what’s the scale HxW values of the output?

It’s JPG extension. The original dimension is 960 x 720, and I’m trying to scale it to 1920 x 1440 (2x).

What version of Win 10 do you have? I was having all kings of issues, until Windows finally installed 1809 update.

What is your system info?

I have the 1803 update. Would you suggest I wait for 1809 to see if it resolves things? Reinstallation doesn’t seem to have worked anyway, and I tried another image to see if it was a file corruption issue, but to no avail. I have absolutely no problem with Gigapixel on my work Mac, so I’m guessing there’s something going on with the software on Windows.

The other thing to check out is your GPU and see if it is supported by Topaz requirements. I think its best to wait for Windows to update because it takes time for Microsoft to get all drivers updated to support the 1809 update. I installed a new GPU and then three days later I get my Win update.

Also having similar problem on latest Win10 pro & Gigapixel. Have tried scaling .jpg image from 32.2 mb file to 2x size. Gigapixel looks like it’s processing but when it gets to the end of the status progress, it creates a 0 byte file and the program quits.

Just tried a smaller file and it completed successfully. Maybe my issue has to do with the file size.

I agree. One can also check what happens if you switch (in the preferences) from GPU to CPU


Hi Bart and Ricci, thanks for the information about system requirements and Preferences. My graphics card (and other system criteria) is compatible with Gigapixel, but for the record, I switched to CPU, then retried the image. Sadly, there’s still nothing being output.

@davidsutphin, definitely sounds like a file size issue in your case. My file’s only 390KB.

If you would be willing to send me the original in a private message I can run some tests with the current version and the version that is currently in test to see if I can root something out. Obviously, I won’t share your image or use it for anything other than this test.

I’ve PMed you, with an additional strange update.

One more note, make sure that Gigapixel is saving as a .jpg not .jpeg. Some photo programs won’t find the long extension, however Windows file explorer will.

1 Like

Not with the current version but still v3 as far as I can recall…whilst still learning(?)

I thought I had specified .jpg but Iike the OP could I find the darned output, no I could not.

It was nowhere to be found so as the input file was still ‘listed’ (as I recall?) I checked all my settings and noticed (again from memory???) that the .jpg extension was not present in the output settings…put it in manually ran the upsizing again and it worked!

I thought nothing of it as bug but more that “I had forgotten to configure the settings…”

So just thinking(?) out loud as it only happened the once, AIG does always revert to the last set output file type but what happens if you inadvertantly change or remove the file extension??? IMO it should highlight an identified error and either default or ask for setting to be “set” before processing commences :wink:

PS I should have paid more attention as what I say above is purely trying to recall what I saw and what I then did!

Sounds like a permissions issue, try running with admin privileges … right-click on the icon and select Run as administrator.

I was able to run the OP’s image with the same settings in the production version and the upcoming release version without an issue. Perhaps there is more to it than meets the eye. I like some of the other suggestions you all have stated. Right now, I can tell you should never set keep metadata to yes on a jpeg unless you are prepared to wait. It gets exponentially slower equivalent to the number of pixels in the output. Never fear, that is being fixed though, so it won’t be an issue for long.

I hope that one day, @AiDon and others don’t have tell me that we are missing exif or other metadata :wink:


Russell, I suspect that all of us appreciate you posting here which shows commitment of Topaz to listening and making great products. :grinning:

1 Like

Thanks to everybody for their help with this, especially Russell.

After much trail and error, I finally managed to get Gigapixel AI working. However, it involved uninstalling Topaz Studio beforehand. When I then re-attempted an export in Gigapixel, my firewall threw up a strange message asking my permission to let Gigapixel modify the output image, to which I said yes — and voilà. There it was, finally, in the specified destination folder. I tried with other images, and they exported successfully too. I’ve since reinstalled Studio, and both programs are working concurrently now.

To be honest, I’m still not sure what the problem was specifically, but there was evidently strange conflict between Gigapixel, Studio and my firewall. Nonetheless, I’m just pleased that the issue’s resolved itself, and hopefully the paragraph above can help others who may experience similar down the line.


Thanks for posting the resolution

1 Like