Topaz crashes when opening as a plugin to Affinity Photo

Just updated Topaz Photo AI to version 2.0.0 and using Affinity Photo Version 2.1.1 on Windows. When trying to use Topaz Photo AI from ‘Filters’/‘Plugs’/‘Topaz Lab’/‘Topaz Photo AI’, dialog box appears saying ‘invoking plug in’ but shortly after, dialog box labelled ‘Topaz Phot AI Cannot Proceed’ with message ‘Error: plug-in has crashed’.

Prior to update Topaz Photo AI ran from Affinity as a plug in and Topaz Sharpen and Topaz Denoise still currently run from Affinity Photo.

Topaz AI does run when activated from the desktop icon.

Have checked in Edit/Settings/Photshop Plugins and it shows that Topaz Photo AI is detected.

Under ‘Plugin Search Folders’ I have tried finding the folder containing the plugin file which i noted from the previous version was at C:Program Files\Topaz Labs LLC\Topaz Photo AI\photo.irdevplugin but this also didn’t fix the issue.

Steps to reproduce issue:.

  1. With an image open in affinity Photo persona and a pixel layer selected.
  2. Click on Filters/Plugins/Topaz Labs/Topaz Photo AI
  3. Dialog box appears saying ‘invoking Topaz Photo AI’
  4. Shortly after another dilog appears saying ‘Error Plug-in has crashed’

Topaz Photo AI [v2.0.0] on [Windows]
Affinity 2.1.1

I have exactly the same problem and followed the same steps as you–thanks for posting; monitoring.

Thanks for feedback,good to know I’m not alone, you do start questioning oneself! I noted that under Denoise and Sharpen folders there are folders for PS plugins and within these folders there are files that I think are used as the link between Topaz and Affinity for example tltopazsharpenaips.8bf and tltopazdenoiseaips.8bf. I have searched for similar files throughout my C: drive using *aips.8bf hoping to find one that contains the characters topazphotoai or similar, but none found so I’m hoping the community or someone from Topa Labs can offer a solution.

I spoke to a user who was having the same issue and they removed the plugin then re-added it to get it working.

Try adding the following folder to the Plugin Search Folders:
Windows C:\Program Files\Topaz Labs LLC\Topaz Photo AI
Mac Applications\Topaz Photo AI

Let me know if it appears after doing this.

Hi Lingyu

Thanks for getting in touch, I have tried your suggestion but unfortunately this hasn’t solved the issue. See screen shots below.

Settings before making the suggested changes.

Settings after the suggested changes

Message that appears when initiating Topaz Phot AI from Affinity/Filters/Plug_ins/TopazLabs/Topaz Photo Ai

Error message that appears within 5 seconds of above initiation.

Topaz Sharpen and Topaz Denoise both work from Affinity.

Also note that I run Photoshop PS6 and Topaz Photo AI version 2.0.0 runs ok from that program.




Hi Lingyu

Thanks again for taking an interest in my issue, I seem to have solved the problem. I found that when I updated to Affinity 2, Affinity 1.10 was not uninstalled so I tried using Topaz Photo AI 2.0.0 from that Affinity Version and it worked. Upon checking the path to the PlugIns for Affinity 1.10 I found a version of the file TopazPhotoAI.8bf with and install date of 4th September 2023, so I assumed the Topaz update installed the new plugin in the older version of Affinity. I then copied the above file to the default folder for plugins indicated in Affinity 2.0.0 and presto it works. Hopefully, future version updates of Topaz will not cause the same issues but at least I think I will be able to deal with it if that’s the case.

Thanks again.


Thanks for letting me know Terry. I’m not sure why the update was causing issues with Affinity, but very glad to hear you were able to fix it.

I let my team know of this behavior so we can try to prevent this in the future.