Topaz AI 2.2.2 won't work on my Mac Pro, all previous revs were fine

Running an Intel Mac Pro with Sonoma. The last AI drop, 2.2.2 will not work. It boots up, but the image takes almost a minute to apperar and then nothing can be donw. The menus are frozen. the generating preview icon is stuck. I can exit the program and thats about it. I tried the drop down Plug Ins menu and the “Edit in” menu within LR. I also tried runnning iy as a stand alone. Same issue. Everything was working great prior to this release.

I run Window but had the same issues on the 2.1.3 release that weren’t resolved through 2.2.2. I downloaded older versions and just went back to 2.1.2. I figure I will run that until the dust settles and the challenges are resolved.

You may already know this but you can grab the older versions here:

Awesome info. Thank you!

Tried going back to 2.0.3. Still no luck. It just freezes. I didn’t have this issue a couple of weeks ago. So something changed with Sonoma or LR in conjunction with the Topaz updates.


Try it again but uninstall the program and and once it’s uninstalled delete all the directories (if they still exist) named Topaz Photo AI. Again, being a Windows using I’m not sure how it works on a Mac.

For me it was in two directories:

C:\Program Files\Topaz Labs LLC and in the users directory C:\Users\XXXX\AppData\Local\Topaz Labs LLC\Topaz Photo AI

XXXX in the link was my name

In my windows registry there was also two files that I deleted but I’m not sure how or if a Mac even has a registry.

Restart and then do the re-installation.

I hope that is some help and you get things back to normal.

On Mac there is only 1 directory with the app. No Uninstall program. You just delete the app.

I found this, it may help.

Here’s the post:

A direct link to the possible solution:

That worked! Thank you. You are awesome.


1 Like