Themis doesn't work at all (from 3.1.0 to 3.1.5)

Mac Os Catalina - iMac PRO - Radeon Pro Vega 56 8 GB
Hi to all, this is my first attempt writing here hoping I’m doing it correctly.
All the versions of Video AI since 3.1.0 stops immediately rendering Themis showing a small red X and showing the error message “Unknown error”.
No way to use it.
Some fixes?
Thank you in advance.

Hey @alberto.mayer

This is not a bug that we’re able to reproduce on our end, please create a new ticket at and our Video AI specialist will be in touch with you.

Please include your logs and your system profile when you reach out.

1 Like

Hello Preston,
Before opening a ticket I would prepare all what you need properly.
Where do I find the Topaz VideoAI logs?
As alternative what kind of log I must search for?
I did a very short screen capture video where i simply select a movie, the I select Themis then I start the preview… suddenly stopped with the immediate Unknown Error.
Forgive me if I’m not experienced with the community preferences.
For the moment I attach the YouTube link with the shot video.
Thank you!

Nor was able to reproduce this; but (shameless hijack), THIS still is a Themis issue:

Motion deblur rasterization

Can you guys look into that too? I was not the only one reporting this.

Version 3.1.6 is the same. Themis doesn’t start showing Unknown Error :frowning:

Themis never worked for me on Intel Mac Pro with W5700x. Tried it with Catalina and Monterey.
Always stops instantly after loading with “Unknown error”.

Hi Roger, Please try to switch to CPU instead of GPU.
I had this suggestion from the Topaz support and it works.
Unfortunately I guess it is pretty slower than GPU but that way you can experiment Themis.
Of course I hope in the GPU fix ASAP.
Kind regards

Hey Alberto, thanks for the reply. Themis with CPU processing only is working!


Hi Roger,
it seems slow but ok for experimenting hoping the will fix the GPU.

Now I’m trying to convince the Topaz team to create the additional option to allow to use a legacy 2.6.4 interface even on v.3.0.0 versions since for me it was hugely practical allowing dozen of parameter variations within seconds and comparing frame by frame.
I’m not happy with 3.0.0 interface…
Cheers Alberto

As of version 3.17 Themis does now work with GPU rendering!

1 Like

Hello Roger.
Please try a comparison between rendering time set to GPU and rendering time set to CPU.
In my case were very similar.
Asking to Topaz team they answered that Themis is written to be used with CPU only so they apparently let the user to choose GPU but Themis continue using CPU.
That was the fix: to ignore the GPU call…
I asked if this is a temporary fixing waiting for Themis written for the GPU but they answered:
"This is not a temporary fix, this is how the model is supposed to be ran :slight_smile: "
Please let me know if your rendering time differ in a sensible way betwee GPU and CPU who knows perhaps they developed a new version in the latest 3 days…