The remove tool

When using the “remove tool” multiple times on the same photo without saving, the final saved photo appears upside down and mirrored. It is correctable in the other program I use, but it looks a bit strange.

Topaz Photo AI [v2.2.1] on [Windows 11]

kind regards

Can you please share a screenshot?

Good day,

I tried to regenerate what I described Without success.

I did some more testing of which I took screen shots. The result is attached to this mail.

In a second attempt starting with the same picture in the first step got a completely different result see picture on page 6

For information the editor I use is ACDsee photo studio ultimate 2024

Hope this helps to improve Topaz [currnly I am on 2.2.2]



(Attachment Topaz 20240106 MG.pdf is missing)

good day,

please find info attached


Marcel Geerts

(Attachment Topaz 20240106 MG.docx is missing)

When you reply with attachments to a forum notification, I assume they are removed because nothing is here.
Please consider posting it in the forum directly.

I tried to regenerate the topic that appeared before, not successful.

on the thing I did od please find the below pictures in sequence

first the origional picture. now in JPEG was in RAW

next step is to remove the lady in the middle


again selected the middle p

art. no saving in between. just continued

and again


and again



final result

I hope this helps to improve

on a new attempt on the same picture as used before please find the result; it is creative!

If you are still experiencing problems with these images please reach out to us at the following link:

Topaz Labs | Support Page

We can help investigate the problems you are having with the Remove Tool to hopefully get a better understanding of the issue you are having.

This topic was automatically closed after 60 days. New replies are no longer allowed.