Terrible performance v 2.3.2 MacOS

Since I updated to v 2.3.2, it is actually impossible to work with photoAI because of the horrible performance. The program freezes for minutes. Has anyone experienced the same?

The program worked well with 2.3.0 on my MacBook Pro. Is it possible to use this version again or will it download the same models?

The new High fidelity upscale models are quite slow, yes.
Still everything mostly takes some to several seconds, not minutes.

But then I have an M2 Ultra here.

Same here, 2.3.2 has made PhotoAI completely unusable. Image frozen, takes minutes to register a keystroke. Wish I hadn’t updated as had to work with it today

re: M2 Ultra performance

Am also running MBP with M2 Ultra - took 43sec to open a low-res image and have been watching the ‘generating preview’ message for 10minutes now, seems like it’s frozen - this is for a simple x3.91 upscale!

This is beyond ‘quite slow’, this is currently broken.

That is strange, for on an M1 Mac mini I recently upscaled a low res JPG in just a few seconds.

1 Like

how recently? 2.3.2 is very recent - 15th I think

Today

Quick update on 2.3.2 Photo AI lag issue…

Working fine on Mac Studio M1 Ultra 128gb ram running 14.2.1
Extremely laggy on MacBookPro M2 Ultra 96gb ram running 14.2.1

Then there’s something wrong with your install I believe.

I’m not having any performance issues on a plain-Jane M1 Mac mini w/16G ram

Is the MacBook running on power saving mode by chance?

no - not running in low power mode.

Thanks for your thoughts on the install jo.vo

In my experience software either installs and runs, or there is an error and the install fails - and software doesn’t open.

will wait to hear back from Topaz before trying a re-instal.

I tried to reinstall twice yesterday, but that didnt have any effect. My Computer isnt running in Power Safe mode either.

Thanks Sebastian, good to know.

Out of interest what system are you running?

Well you can tell from your other (slower) system where it works that there’s something wrong on the M2 Ultra.

And I’ve read reports of previous installs leaving fils in the MacOS system folder that caused trouble with newer versions until they were manually deleted.
As unusual this is on macOS…

Unfortunately I can’t find the respective post and thus cannot really tell where to look for / what to delete.

Thanks Jo.vo,

raised this as a ticket and am hoping someone from Topaz will get back to me.

Are you saying you’ve read about previous installs of Topaz software leaving problematic files on the system, or software installers in general?

I did notice that the update for Photo AI seems larger than usual, and the update to Gigapixel was huge!! maybe 36gb…?

It was especially about a Topaz product - TVAI I think.

This is why I really prefer DMG installs over PKG ones: everything is in one folder in the Apps folder. If you delete that the app really is gone.

I found one report; apparently it helped to delete the .plist file (although this was another issue it’s still worth a try)

You can choose one of these two workarounds to resolve this issue:

Let me know how that goes for you and we will make sure to reach back out to you to let you know when this is resolved.