TAI 3.0.4 buggy - zoom below 100% not possible

When importing CR2 images directly from a directory or from LRC, they get automatically cropped and you only see the top left part of the photo.

Steps to reproduce issue:

  1. Open Topaz PAI
  2. Browse for photo(1 or multiple - makes no difference)
  3. Preview images - cropped
  4. Cannot Resize below 100% and cannot move photo in the preview panel

Additional Information
TAI treats the visible section of the photo as the whole photo, meaning, that the export only exports the visible part in TAI. So only the cropped top left is exported too.


Topaz Photo AI [v3.0.4] on [Macbook Pro M3 Memory 24GB and Sonoma 14.5]

Original Shot
_MG_8113.CR2 (16.4 MB)

What TAI shows

Which Lightroom Classic are you using:

  • File > Plug-in Extras > Process with Topaz Photo
  • Photo > Edit in > Topaz Photo AI

Also are you using any form of in camera crop options?

LRC 13.3.1 Camera Raw 16.3.1

I only use:

  • File > Plug-in Extras > Process with Topaz Photo

But as I wrote in the issue, this happens when I open CR2 files directly in TAI Photo too. I tested with a jpeg file and that worked fine, even CR3 seems fine. So possibly only related to CR2.

No crop options being used either - the process was started outside of LRC too and had the same result.