Studio 2 version 2.2.0

I just finished installing studio 2.2.0 and in the process of checking that it is functioning, I selected the update software button. I expected to see that updates were not available, but the message read “invalid server response, error 2.” I repeated the installation using the windows installer, and the message remains the same. Anyone else have this experience?

3 Likes

@XiaoLin

Yes, same here.Topaz%20Studio%202%20Update%20Error

1 Like

I believe that in directly d/loading Studio from the Topazlabs d/load page, you also are d/loading a newly implemented installer framework. I suspect that in-app installer has been suspended so that they can change the in-app installer framework.

Thanks for your reply, Jack. Does that mean there is nothing I can do until the in app installer is repaired? I’ve tried several times to re install via the Topaz Windows Download Page.

Thanks for your reply, GreyFox. Have you found a solution?

I d/loaded 2.2.0 about 4 hours ago - it works perfectly on my Surface Pro 4 - so the current installer does work … at least on my Win 10 system.

Good to hear that, Jack! Did you update using update under the help menu or did you go to the windows download page. I still get an error message on my computer: invalid server response:2, which directs me to topaz labs download page.

Direct d/load from Topazlabs d/load page :slight_smile:

Jack, to be clear about this, are you saying that when you click on Help->Check for Software Updates on your 2.2.0 installation, you don’t get the Update error dialogue shown in earlier posts in this thread?

Can you provide a screen shot of the dialogue you do get.

Unfortunately No. I’m waiting on clarification from @Torcello that he does or doesn’t actually have this issue, but as you know reinstalling via the Topaz Windows Download Page doesn’t appear to work (at least for some).

The issue you raised, and I confirmed in this thread is not that the new version of Studio doesn’t run, it is that the check for updates produces an error.

Nope - a direct d/load from Topazlabs.com/downloads

Hi Jack,

I understand you did the update by downloading 2.2.0 directly from the download site, but that wasn’t my question.

Now you have it installed and running as you say “perfectly”, if you click on Help->Check for Software Updates,. does it go away, check and then tell you that there are no updates available (or words to that effect) as it should, or does it produce the invalid server error message that this thread is all about?.

Yes, that is correct. version 2.2.0 seems to work well, though I have not checked all functions, but my auto update gives me the error message as it does you. (and I suspect a good number of other people that have not tried to update.)

1 Like

Yes, Invalid Server Response 2 error here as well.

4 Likes

I have the same error. I also noticed the my AI Mask is not in this studio version. Back to the drawing board for Topaz.

1 Like

Not all of the AI plugins are currently integrated into TS2…

I can confirm that I behave exactly the same way as XiaoLin did…

Exact same behaviour : Update error, Invalid server response : 2

1 Like