Studio 2 update fails

I am running Studio 2.o on a Mac 10.14.6.

When I open Studio, is says there is an update available, but when I click “Yes” to install it, Studio shuts down but no update occurs.

Reopening Studio confirms Studio 2.0 is the installed version, no automatic notice appears to update. If I click “Check for Updates”, I am told there is one, but clicking “Yes” to install still just shuts down Studio with no update being done.

How do I install the update?

I had the same problem with windows version. I had to Uninstalled the Studio then download and install the latest version.

1 Like

Download v2.0.13 from Download and use that installer. Note that it will uninstall your previous version also.

I had no problems installing 2.0.13 on MacMini with 10.14.6

The installer framework we use is a sore spot for many of you as well as us. We are working on a replacement that will increase its reliability. Like you, if an update is available, I just want it to update.


I was able to download the latest version from the website and just ran the update over the existing installation. It worked fine, but the auto update feature would be much more convenient.


Going from 2.0.13 to 2.1 lead to a new problem for my system. The in-program update notice worked, but the install failed. I then used the direct download method, and after uninstalling and installing the new version it failed to run with a cascade of missing installed component dialog boxes. A second reinstall from scratch also failed. I eventually discovered the advice to install the C++ distribution files from MS (vc_redist.x64.exe) and reboot. After completing that the third attempt was successful. The need for the C++ files is not a new requirement, but evidently the ones I had installed previously that let 2.0 run successfully, were not sufficient for version 2.1.

1 Like

A Fine Sentiment. A bit like saying to someone with a broken leg “That’s an interesting injury, here borrow my sticking plaster.”
The reality is the software does NOT install.

Please raise a support request at the Topaz Labs main website.