Studio 2.3.0 and Histogram

Being very happy to install TS2 2.3.0 (finally AI denoise ready for use), however after a day of use I found another bug - histogram is dead. It shows the original file data, but it does not react on anything you do with brigthness, exposure or so. Very disappointed with this. Now I am again torn beween TS1 with functional Histogram but no AI denoise - or TS2 with AI denoise but no functional histogram. Frankly I am being tired by longwaiting for new updates, then get them while new bugs are introduces. Anybody else having problems with Histogram&TS2 ?

Fully agree! There’s one more bug - after installing I discovered that TS2 is not to be found in the LR Photo/edit in menu. A good case of What Topaz hath giveth they taketh away! I too am getting very tired of the apparent incompetence of programming/verification process.

1 Like

After installing 2.3.0 - I have still option for editing in TS2 right from LR (6). Do you use any higher version?

LR Classic (9.1) Mac OS 10.5.3 Catalina. The odd thing is that TS2 is accessible in PS Filter menu. It really ticks me off that these sorts of things still happen and it’s due to lack of due diligence during final testing. I submitted a request yesterday - no answer yet.

Even on Windows the Histogram doesn’t always display correctly …

+1 Exposure (OK)

+1 Exposure (Wrong)


-1 Exposure OK


Please raise a support request at the main website so it is passed on to the developers.

I believe the install instructions say it must be run as a standalone first for it to be included as a plugin. Try that and see if it will install in LR but also make sure that you restart LR if it is open as with both LR and PS plugins are loaded at startup and cannot be installed dynamically.

Is anyone else able to make the crop tools ratio lock work?
Locked or unlocked the crop does not hold the ratio for me.
This is standalone on Win 10.

@JohnG50D I just tried the crop tool set to original ratio and a 4:3 ratio and it held those ratios while moving it. I have Windows 10 v1909

I raised a ticket 218309 - re Histogram not working in TS2.3.0
will inform how the things turn out.


I finally got this figured out.
I uninstalled previous install of Topaz Studio 2.3.0 and reinstalled the application. This install went fine, but when I attempted to invoke Studio it was not available in the Photo/edit menu. Studio V1 was there as before, but not Studio 2. (I never uninstalled the original.)

However there was a new item ([FULL_NAME]) near the top of the Photo/edit menu.

When I clicked on it I was able to complete the file transfer to Studio 2. Viola!!

Problem solved - almost. I would however, like to replace “[FULL_NAME]” with "Topaz Studio 2” and have it sequenced where it was originally below “Topaz Studio” (the original legacy app).

I would also appreciate it if the engineers would take a little more time in the verification process before releasing their updates in the future. This shoddy work will not help Topaz in it’s current efforts to gain sympathy or understanding concerning new pricing policy changes.

Today I´ve received mail from Ashley Tarp - confirming the issue

There is a fix for this in progress and we are working as fast as we can to get it out to you,

We are placing this ticket on hold to indicate that the fix for this issue is in progress and we will reach out to you when we have a fix ready for you,