Studio 2.2 disappointing experience so far

To start off, I was using Studio 2.1 or whatever the previous version was with no problems. I finally acknowledged the update notice and it went into it’s auto update process. Lot’s of errors with wrong versions of various components. I eventually just had to ignore them. Studio 2.2 finally installed, but would not run. It gave a runtime exception… So I checked the forum and seeing a few other complaints but not this exact one, I decided to do a clean install. By that, I mean I used a commercial uninstaller program to remove studio 2 and all it’s left over registry entries and files, over which there were many! (as an aside, when will software engineers on the windows platform create an uninstaller that actually uninstalls everything?)

I then downloaded the installer and it installed without a hitch. Now to use it. I first went back to a Fuji Raw file (not an x-trans raw, but a bayer raw from an XA3) that I had been working with before. Right off the bat the blue sky was an ugly pink. I used another commercial product to create an Adobe compatible DNG file, which opens just find in PSE. In Studio 2.2 it’s an even uglier shade of pink than the raw conversion, no amount of fiddling with white balance controls can make it even acceptable.

So, until this is fixed, Studio 2.2 is useless to me. Oh, by the way, the updater on my old version of studio 2 also told me it was uninstalling the beta version, which is just wrong. I should have stopped there, this new version is clearly flawed in many ways. Can you make the previous verison installer available so we can go back to a working version of studio 2?


Problems installing TS2.2 on my iMac, too. Errors with wrong version of components. Then when install finally completed, 2.2 would not run because of missing executable.

1 Like

As has been mentioned in many threads, Studio 2 at this point in time is not recommended for use with RAW files. Whilst it may open them, unwanted color casts are often observed. DNG is a RAW format, and falls into that category.

It is recommended that you convert your RAW to a TIFF file in another application before using Studio 2.

Or just use Studio 2.2 as a plugin from Photoshop or other photo program. This is the fastest way and it works. Topaz has told me that getting RAW fixed is a priority and I have downloaded v 2.1.13 and installed it in the meantime.

Thanks for the information. I must have missed the recommendation not to use 2.2 on raw files, I did do a search before I posted and must have not used the right keywords. I am looking for the right plugin host as we speak, I typically use Iridient X-Transformer for all my fuji files as I also have an X-trans body and it converts to DNG. The real problem with this recommendation to use other programs for raw processing and use studio as a plugin is that the main Topaz tools I use also work just fine as plugins, thus eliminating the need for Studio altogether. Not sure that’s what Topaz had in mind and I am sure they will get raw processing fixed, but in the meantime I will have spent money on an up to date plugin host program. The ones I am using now are are all older versions need updating.

@WayneDWilson A good host program will do more than just allow plugins. I would suggest you try Affinity Photo. It is similar to Photoshop in many respects and is not expensive to buy. Many people on Topaz forum use it. Here is the link. Affinity Photo – award-winning photo editing software

To use plugins, you must go to Edit menu > Preferences > Photoshop plugins and add the topaz directory. It will say unknown but thats ok.

The FujiFilm supported Raw cameras supported by Affinity Photo in this list might be of interest to you.

I have just tried several Fujifilm .RAF raw files from an X-Pro 2, together with their counterpart .DNG conversions from Iridient X-Transformer in Affinity Photo. (The samples were downloaded - I don’t have a Fujifilm camera)

Affinity open both types in its Develop Persona, but as there was no noticeable difference between them at that point, one could possibly not bother with the Iridient conversion, and just develop the .RAF files in Affinity Photo.

Affinity Photo has a limited time free trial period available

Thanks for taking the time to test fuji raw and dng files out. I have used affinity photo, but lately I find myself wanting to work more simply by starting out with a file manager, culling files, sometimes launching raw versions into tools like denoise-ai and sharpen-ai and then finishing them off in luminar (all via plugins, so no need to do time consuming save and re-open operations). The best program so far for that is an older version of ACDSee that I have, the plugins transform it into a modern tool and I just ignore it’s editing features and mostly use it as a file manager. Both ACDSee and Affinity handle the topaz and luminar plugins ok, but only one has a file manager. So, I have tried and own a few varieties of software in an attempt to streamline my workflow. The more automated treatments available today do pretty much everything I used to spend a lot of time on in pure editor tools, so I find myself using tools like Affinity less and less, and the less I use them the more I forget how to use them.

Hi Wayne,
I have used ACSee (various versions from 14 through 17) and currently ACDSee Photo Studio Standard 2019 as a digital asset manager. Whilst it can display RAW files (and handles both the Fujifilm ,RAF file and Iridient X-Transformer.DNG files I looked at today, it can only edit them to 8bit.

I have Affinity Photo linked to ACDSee as an external editor , and use that to develop the RAW files I work with (mainly Sony .ARW), and as I mentioned in my previous post it handled both the .RAF and Indient DNG files OK. I should perhaps add that there are some DNG’s that ACDsee doesn’t seem to be able to display.

I have both Studio 1 and Studio 2 also linked to ACDSee as external editors, but as Studio 2 in particular doesn’t presently handle RAW properly, and can’t do image layers, I mostly develop in Affinity and use my Topaz software as plugins to that.

Same problem here
in a 2019 MBP running Catalina 10.15.1

I just had the same experience! Waited over 20 minutes for nothing. What a disastrous experience. I have never seen anything like this before after so many years (since mid 80’s).