Studio 1.11.8 Update crash

Once again the latest update to studio fails to work. Had to completely uninstall and then reinstall.

2 Likes

I have been plagued with the same issue but have found that if I download the update from Topaz site as opposed to allowing it to be updated through the application that all seems to work.

1 Like

O.K., I’m having to uninstall then reinstall from the download from the Topaz site. R U doing something different than that. If so, please explain. :grinning:

I was hoping that by now this update failure problem would have been resolved.

David

On this update I initially tried from the application with the same result as you. I then proceeded with the update form the Topaz site without an uninstall. It started and then a message came up “it appears that the application files may be corrupted, would you like to uninstall first?”, or something to that effect. I clicked proceed and the uninstall and install completed without any errors. I guess my interpretation was that I did not have to manually initiate the install before doing the upgrade from the Topaz site.

Larry

O.K, we did the same thing save for you having the new install take care of removing the old program files before installing the new ones while I did the removal manually. I prefer my way only because this way I’m certain everything gets uninstalled. In the past the auto uninstall would occasionally leave some files behind that caused problems. But as long as the new update runs I don’t see any difference. Thanks for the explanation.

I got the same errors in attempting to update from within Studio. Seriously, I’m not willing to manually uninstall, hunt for Topaz Studio download site and install. Topaz people need to do better testing before release of updates.

If you just go to the www.topazlabs.com/downloads page, it’s right there at the top – no hunting required. Also, the installer on that page will automatically uninstall the current version for you – automatically (not manually)

We’re still looking at the E_Fail error, but don’t yet have a solution. It happens in an unpredictable manner, inconsistently, and is not reproducible here in the office. We hope to have it fixed soon, but if we can’t recreate it, then it’s incredibly hard to fix.

1 Like

I’m getting here to on an iMac running Mojave. It won’t update, and the automatic uninstaller also fails.

Delete the application folders and the installer should work fine, from the Downloads Page.