Square Pixel ram issue

Movie 480x576 β†’ 1920 Iris and square pixel
No problems with any other settings and with older versions of Topaz.
But with this movie setting: square pixel
causes a Ram/swap issue +the task ANECompilerservice launches and eats Ram, I stopped it when it got to 90GB swap! and causes the swap to fill and the machine slows down. Never had that process ANECompilerservice and that issue.

MacBookAir M2 24Gb Ram, Topaz 3.32. and 3.34 and 3.35
in 480*576
out 1920x1080 square pixel + crop to fill + Iris manually

Square pixel seems to trigger this problem, not iris alone.

logsForSupport.tar.gz (134.5 KB)
MacBook Air.spx (6.2 MB)

Bildschirmfoto 2023-07-20 um 12.22.16

Apple Process Tool shows this


Thanks for reporting this issue. We’re working on a solution for a memory leak when using certain models on Mac systems that is scheduled to be released in our next Video AI beta. I will notify you in this thread as soon as it is available.

thx !

It is not square pixel related. Just tried up upscale a HD video to 4K with Iris, same thing, swap goes over 50gigs

1 Like

Bug is still present with 3.3.8
Occurs with every setting most of the time.
Memory use rises and fills the swap. Seems to be the memory leak issue of another post here.
But only on my M2 MacBook Air. A Mini M2 and Mini M1 are not affected.

Thanks for testing that,

Our dev team has let me know that this should be fixed in the 3.4 release. Thanks for your patience and cooperation in testing!

1 Like

Lastet MacOS update 13.5 (22G74)
M2 MacBookAir:
Proteus upscale to HD worked on some files. But same problem with iris. Square pixels seem to trigger this as well.
M2 MacMini:
Had no issues before, but maybe I just was lucky, had a few long render jobs. They worked.
Now tried iris on a 4k upscale and the Ram issue is here too.
Topaz 3.3.8 on both machines. The MiniM2 has a fresh OSX install, new machine with no 3rd party software

The 4k upscale on the MacMiniM2 is now running, with Proteus. Ram problem occurs within 10sec after starting export, so it seems to work. Iris caused the problem with that file.

This thread can be closed
The version solved the Ram issue. Both my M2 Macs ran it for >2 days without any issues.
There is more useful info in the corresponding thread about the Alpha version.

thx Topaz team !

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.