Some characters in folder names delays Recent thumbnails appearance and crashes Photo AI

If I try to open an image located in a folder its name contains some characters with diacritics, the Recent images thumbnails are not displayed for a long time (20-30 s), only placeholders. If the image is attempted to open during this period, image loading takes longer time than usually and terminates by Photo AI crash.
The issue can avoided only by checking ‘use Unicode for worldwide language support (BETA)’ in Windows Region and language settings but it conflicts with many applications in my computer.

Steps to reproduce issue:

  1. With Photo AI closed, create a Windows folder with a name containing a character with diacritics, e.g. ř, Ř, ž, Ž (see also attached screenshot) and place a raw photo image there.
  2. Open Photo AI and open the image using ‘Browse Images’
  3. Check whether regular thumbnails appear in the right column (‘Recent’). If there are only placeholders (see attached screenshot), the application crashes, in my computer, before completing image loading or immediately after.
  4. If the thumbnails contain real photos, the application works correctly. In such a case, close the Photo AI and try again from point 2 - the issue usually appears.

Topaz Photo AI v1.4.2 on Windows 11
Placeholders only
DxDiag.txt (96.5 KB)
Photo AI log recorded while crashing:
2023-07-23-13-25-14.tzlog (16.7 KB)

I followed the steps you gave and wasn’t able to reproduce the issue. I had a folder and a file with a diacritic in the name and everything loaded fine.

What kind of folder is your MyFiles location? Is it on the hard drive or is it cloud storage? It sounds like Topaz Photo AI cannot access those files for some reason.

What is your computer current region setting? You can find this in the same menu that has the Unicode Beta setting. I can change my region to test this.


Many thanks for your reply and attempt to reproduce the issue.

My disc with MyFiles folder is the local SSD and I have no problem to access it.
Simply, renaming the same folder using diacritic and without it (e.g. Říp → Rip) leads to the appearance or absence of the issue, respectively.

My region settings is Czech language, Czech local format, and Czech Republic country.

To get the issue fully reproducible it is better to include clear Recent list and restart Photo AI:

  1. Create/rename, using diacritic, a folder containing a raw image (the image name can be in pure ASCII)
  2. Open Photo AI, Clear Recent, and Close Photo AI.
  3. Open Photo AI, Open Image located in the folder with diacritics. Now, there is usually no problem.
  4. Close Photo AI (confirming exit without saving).
  5. Open Photo AI → now a placeholder appears, instead of a thumbnail, in Recent.
  6. Click the placeholder → the image starts to open but Photo AI crashes after some seconds.


I changed my region settings and made sure I had the worldwide language support setting turned off.

I tried your reproduction steps and could not reproduce the issue. For now I would recommend removing these characters from the file path.

Does this happen for all locations? Does it happen your C: drive as well, such as your Desktop?

If the folder with diacritic is copied to C: drive, e.g. Desktop, the issue persists. I also freshly downloaded, installed, and activated a second copy of Photo AI 1.4.2 on my other Win 11 computer (HP laptop). Again, the same behavior.
On the laptop I even tried to convert all language and region related Windows features (including UI language) to English version, just preserving two input languages. However, the usage of diacritic still causes appearance of placeholders in Recent and subsequent Photo AI crash. So, the cause of my issue is now very mysterious.
Yes, I will follow your recommendation and put the images to be processed using Photo AI in a folder without diacritic.
Lingyu, thank you for your effort.

I appreciate your flexibility on this. If I see more reports I will restart my investigation. For now, avoiding those characters is necesssary.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.