Slow Processing

Just upgraded to Gigapixel v7.0.1 and find the process to take so long.
For an image size 4016x6016 px to amplify 1.5x, it takes 16 minutes !!!
With my v6.3.3 it was way faster…
Is it normal or is something wrong ?

1 Like

please provide a sample image and maybe some specs of your machine. 16 minutes sounds a bit long indeed.

Specifics of my MacBook Pro 16” :

Processor: 2.3 GHz 8-Core Intel Core i9
Graphics: Intel UHD Graphics 630 1536 MB
Memory: 32 GB 2667 MHz DDR4

MacOS Sonoma version 14.3
Storage : 647 GB available of 1 TB

Working on my pictures in Lightroom from an external storage device.
This picture size 3638x5458 px, upsizing 1.5x in Gigapixel took 16 minutes !

Would appreciate your feedback, was working faster before update…
What should I expect ?

Thank you

1 Like

I think the main reason for the slow processing might be the integrated graphics unit. Upscaling to factor 1,5 did not work on my end via Gigapixel 7.0.2, but upscaling x 2 was done within a few seconds with a dedicated gpu. I will test it on an rx vega 8 integrated graphics too.

ok will wait for more feedback…

Well, my RX Vega 8 integrated graphics do the upscaling within a few seconds too. :eyes:

Well I tried to process the 2x, and for me it stays as slow.
So you might be right, probably the graphics that do not support…As a matter of fact my laptop gets hot while processing the image.

@Imo was correct about this.

Although the Intel video card is supported, it doesn’t have its own dedicated VRAM to utilize. Instead, it utilizes the system’s RAM to process images. If the system RAM is being used at that moment then there won’t be enough to dedicate to the Intel video card causing the slow processing speeds.

You will want to keep as many things closed as possible when editing. If you can, use Gigapixel as a standalone outside of Lightroom. I’m sure Lightroom is using a lot of RAM by being open and holding images. You will experience much faster processing speeds with the Intel video card like this.

However, if you want to have faster processing speeds and be able to use Lightroom at the same time, then I’d recommend getting a dedicated GPU.

1 Like

There are some very interesting new comments in the discussion about Release 7.0.2 on this here:

It appears that v7.0.2 processes images quite differently than v 6.3.3 did.
Your suggestions about dedicated RAM would affect v 6.3.3 and v. 7.0.2 in pretty much the same way.
If the dedicated RAM was really the issue then one would not expect there to be such a dramatic difference between processing speeds of the two versions of Gigapixel AI.

In my case both versions of Gigapixel AI appear to recognize my laptops internal Radeon Vega 8 graphics correctly.
I’m not sure both versions ‘correctly’ use all of the 8 graphics cores and the 512 shaders simultaneously though.
I don’t know, but if the new version somehow only ran on 1 of the 8 GPU cores for example, then this would certainly explain the dramatic increase in processing time that I’m personally experiencing.

When I have the time I will go try to see if I can find a good performance monitor for Win 11 that reliably tells me which of all those numerous cores are really being used while Gigapixel AI processes images.

This extreme difference in processing speed between the two Gigapixel AI versions is very odd, to say the least.
There must be something in the software or in the models that explains the dramatically slower processing speeds so many users are experiencing and complaining about.
The two comments linked above provide great information about a major difference between the two Gigapixel AI versions that’s worth taking a closer look at and for Topaz Labs to be investigating how the changes can affect so many users so negatively.

2 Likes

I just tested it on my Win 11 laptop with an AMD Ryzen 5 3500U CPU, 20GB of RAM, and just like your machine also with Vega 8 integrated graphics.

Scaled the image up by 1.5x
I used the AI model High Fidelity v2
The other settings I picked were
Minor Denoise 65
Minor Deblur 5
Fix compression 46
Face recovery and Gamma correction both turned off.

I think the result looks great but it took Gigapixel AI v 7.0.2 a whopping
4 minutes and 12 seconds to process the image on my laptop.

Strange. I can type in an upscaling factor of 1,5 but the result has exacrly the same size than the original!

That is indeed very odd. When I upscale it by 1.5x it upscales it all correctly, it just takes very long. But it also takes very long on 2x or other factors.
Does it let you upscale it by a factor of 1.5x when you enter the dimensions manually (2729x4094)?

PS: I just changed the preferences to test upscaling the image via the CPU and that took my laptop 28 minutes and 20 seconds for the image to process, so even longer than it takes brohrer.

As already mentioned, my processor is an AMD 4 core with 8 threads though and brohrer has an 8 core intel I-9 processor which should indeed be considerably faster than my CPU making his processing time of 16 minutes seem a very reasonable CPU processing time compared to the time it takes my CPU to process the image.
So in brohrer’s case this might possibly even hint towards the Gigapixel AI on broher’s machine simply just using his CPU instead of the internal graphics.

Hi brohrer, I did some testing with the image you uploaded on my laptop, you’ll find the results in my other comments here.
My tip for you is to go into the preferences of your Gigapixel AI stand alone app (Edit>Preferences) and to see if it lets you select your internal graphics (not AUTO, not CPU!) and see if that has any impact and improves the processing speed.

@esther.huynh @alexander.zhang
Just to note it seems speed issue is related to processor selection/detection or cached preference selection across versions. Need some further investigation.

1 Like

Hey JYG, just tried this and it was way faster…3 minutes! Does the stand alone app always work faster than editing from LR ?
I’m not a gig nor tech person…so I do it the more convenient way for me.
I appreciate your help, and will try this thru LR to see if any difference too.
Thanks a lot

Do you have region settings set to Germany by chance?

In Windows? Yes. But I tried both to type in 1,5 and 1.5 with the same result.

Zumindest in TPAI funktioniert das Upscaling mit nicht-ganzzahligen Faktoren nicht, solange man ein Komma für die Dezimaltrennung eingestellt hat.
Und zwar egal. ob man 1,5 oder 1.5 eingibt. Auch der Wechsel des Tastatur-Layout auf US bringt da keine Abhilfe, sondern:
Du musst hier tatsächlich das Zahlenformat auf US (oder ein anderes Land, das einen Punkt als Dezimalseperator hat) stellen. Erst dann geht es - in TPAI, wahrscheinlich ist das in GP aber das gleiche Problem.

P.S.: Das gilt jedenfalls unter MacOS, auch hier ist es aber sehr wahrscheinlich, dass das unter Windows auch so ist.
Also unter Einstellungen/ Region / weitere Einstellungen den Punkt als Dezimaltrennzeichen auswählen. Oder der Einfachheit halber gleich die gesamte Region auf US umstellen…

1 Like

Ach so! :neutral_face:

You’re welcome, glad it helped even though 3 minutes is seems kind of long for processing an image of that size, I think.
The quality of the results using the new AI models may of course very well justify that processing time, I have no idea how much computing those new models involve, but it does seem kind of long to me. :slight_smile:
Upscaling a much larger photo in v. 7.0.2 (to later crop the relevant part out of it) took my laptop over 45 minutes to process (with using the GPUs) and I don’t remember v 6.3.3 ever taking THAT much time for upscaling any images. I’m thinking about uninstalling 7.0.2 and go back to v 6.3.3 for the time being until the other major issues in V 7 are fixed, like the missing comparison window. If I do I’llprobably test upscaling your image again in v 7.0.2 with the old standard model and compare it to v6.3.3 just put of curiosity to see how much faster the old version really is, but I’m not there yet.

Also I don’t use photoshop or lightroom anymore, I just do most of my editing in GIMP instead as I don’t deal with RAW files anyways and the free GIMP does all I need and then some and overall I do find it more intuitive to use, especially with regards to the various filters.
Therefore I have absolutely no idea if the performance of the Gigapixel AI plugin in lightroom or photoshop is slower or the same as the standalone.
I also don’t know of there is an option to change the preferences for the AI processor in the plugins or not., but I’m sure someone else here will know.