Sharpen not working in 2.4.0 | Selection Option

In the latest version (2.4.0) no sharpening seems to take place with any of the sharpen models. In split view there is no detectable change in sharpness regardless of model or settings used. Other enhancements seem to work as before, but not sharpen.

Topaz Photo AI 2.4.0 on Mac OS (Sonoma)

3 Likes

Many people seeing this issue.

No issues for me: all sharpening models fine.
Mac Mini M1 16GB Sonoma

The problem is:
Preferences > Subject Detection set to None is not processing sharpen.

Of course not. You have to select subject detection to All if you want it to sharpen the entire image. Or chose another mode and then use a brush to add or remove. For example, I selected Portrait here but it also included other elements that I don’t want sharpened:

But in the previous versions you didn’t have to do that. If “Preferences > Subject Detection set to None” then sharpening by default was applied to the whole image

Thank you people; that solves the problem. It has to be the most ridiculous setting there is. You choose to sharpen an image and there is a setting which sharpens nothing? And then, to compound the felony, it’s made the default? Come on Topaz!

1 Like

Go to Settings and change the Default Subject Type to what you want it to be.
None is not a ridiculous setting. It gives you blank canvas on which you can use the brush to define what you want to be sharpened. For example, say I only wanted the sharpen the hat in this image:

Unfortunately, that only makes sense if “All” was one of the default settings. It isn’t.

1 Like

I am having the same issue with no sharpening. Thought it was just me. Just downloaded it today. Tried rebooting the computer, a Mac, and re-downloading the program. Nothing worked.

In the sharpen enhancement, go to the “Selection” tab and set the “Auto Mask” to “All”. Unfortunately, you have to do this every time because you can’t set “All” as the default. Mine was set to “None” which now means ‘no sharpening’ whereas it used to mean ‘no selection’ (i.e. sharpen everything). Unfortunately, this wasn’t caught during testing.

same problem here - M1 with Sonoma

ok, pls fix this - AutoMask set to All does the job, thanks

This is a “new” feature. Previous versions didn’t work this way.

I tried this, and it still didn’t work. I can do the sharpening and sharpen AI, but not Photo AI. All the rest of the components work.

The changing the selection to “all” did work, but it;s not possible to see the changes on the peview because the mask covers all of it.