Sharpen AI very slow on 3970x w/ RTX 2070 Super

MSI TRX40 Creator MB
AMD 3970x Threadripper
G.Skill DDR4 3200 4x32GB (128GB total) (XMP enabled in BIOS, default settings)
nVidia GeForce RTX 2070 Super 8GB
SSD 2TB SK Hynix P41 Platinum PCIe4.0

Editing photos shot with Sony A7Riv camera, 50MB RAW files typically.
Running Sharpen AI as a plug-in from within Lightroom Classic.
All files stored locally on ultra-fast SSD c: drive.

Puget LRC Benchmark: 1113-1177 range

Editing a single photo in Sharpen AI, using Auto to determine sharpening profile: rendering (from time I hit “Apply”) takes over 2 minutes per photo. This makes editing incredibly tedious.

In Sharpen AI: AI Processor = nVidia Card, Memory Usage = High

Is 2 minutes expected for this system? What if anything can I do to speed up this performance?

Update your graphics driver.

Disable SMT and prefetch of L1 in Bios for higher performance of gpus paired with ryzen cpus.

It should be seconds not minutes.

1 Like

Graphics driver is fully up to date already.

MSI TRX40 Creator Motherboard, inside that BIOS I cannot find any prefetch control at all. Finally found SMT Disable/Enable by changing PBO from Auto to Advanced, but no prefetch options appear. In CPU Specifications (read-only) the BIOS says the CPU L1 cache is 1 MB, doesn’t say enabled or disabled. Tried looking online but cannot find any examples of tweaking within this specifc BIOS menu. Gigabyte, ASUS, seem to display this prefetch control from what I’ve read but nothing in this TRX40 Creator BIOS. This is the very latest BIOS from MSI.

When changing PBO to Advanced, some modes pop up including: Gaming, MSI Gaming, and Performance. I enabled Performance, didn’t expose any new tweaks. Disabled SMT, left Performance Mode enabled, rebooted, and zero improvement in Sharpen AI. Cinebench R23 multi-core slowed down from 42000 to 31000. Guessing that disabling SMT without simultaneously disabling the L1 cache is not a winning formula…

Depends on the workload not the benchmark.

My Quadro RTX 5000 (2080S type GPU) does Sharpen a 100 MP Phase One image with the Motion Model in one minute at the same time as i do a export in Video AI, paired with a 3960X TR in a Asus trx40 prime board.

Yesterday i did game COD MW II MP at 70 fps in 1200p with the same card paired with an 8 core intel CPU and at the same time i did export with Video AI with 8-9 frames (pal to 1080p, Proteus)

1 Like

Thank you Thomas for this helpful info. I just completed a 90 minute odyssey:

  1. double checked BIOS version, of course a new version was recently available so I updated using M-Flash
  2. On completion, Windows booted to blue screen. An hour later, finally got Windows back online, still a couple of weird issues but it’s working. (1) Windows Update is stuck on 0% installing for “Security Update for MS Visual C++ 2008 SP 1” even after 5 reboots… and (2) “System Info” brings up “Can’t collect information”. Ran the stop winmgmt / start winmgmt commands I could find online, they aren’t fixing it.
  3. Anyway Windows is working, so opened LRC and tried a photo… Took only 1 minute this time, instead of 2 minutes. So something improved for sure.
  4. Went back into BIOS, turned X-AMP and PBO both to OFF, rebooted, rechecked LRC, same speed. So rebooted again, re-enabled them, and LRC still at 1 minute instead of 2 minutes.

Maybe there was some hidden bug in the BIOS, not sure. But 1 minute sounds like what you’re getting so I guess I’m on the right track. Bugging the heck out of me that I can’t find the L1 prefetch controls, the AMI BIOS on this MSI motherboard doesn’t look anything like the red/black colored MSI BIOS screens I see online. I’ve clicked through everything, enabled everything to check if prefetch is exposed, am just stuck. This update didn’t change the GUI at all so no joy there either. Anyway thanks again for the tips.

The SMT is located in the CPU Freatures Menu.

“Simultaneus Multi-Threadting”
Short “SMT”

In the Advanced menu you should find “Above 4G memory”
You can activate this, when the system does not boot after, deactivate it again.

A suplier of mine did say to me that i should activate it for full pci-e performance.

I don’t find L1 cache, maybe msi did not implement it.

People tend more to care about oc than stable processing.

Ryzen is bad at oc, Ryzen 2 (3000) has its sweet spot at 3800 mhz, after it just goes warmer with less performance increase.