Sharpen AI v3.1

Lightroom CC doesn’t support plug-ins - only Lightroom Classic does.

1 Like

According to me, Multi GPUs only worked in 3.0.0 (3x7950 HD - I7 3770k Delidded - 32GB - W10). It’s the only way to work “fastly” for me.

I know this is an experimental feature, but if you could solve this bug in >=3.0.1 I would be grateful ! (That would stop the emotionnal rollecoaster I feel at every new version and avoid me to roll back to 3.0.0 every time).

Another thing would be to optimize the cursor in masking. It’s a pain to use in 2021 (why not using mouse wheel to increase/decrease the size of the cursor, and press “Alt” to substract mask ?).

And last thing why such differences between CPU and GPU processing ? (CPU is still better)

Thanks for your consideration !

1 Like

Ticket submitted, thank you.

This will be my first update and I am confused about the difference between “online” and “full” The full whatever is humongous and the online whatever is only 7.3 MB. I don’t want to mess up my existing version. Which to do? I am running on a Mac Mini M1. I do not run from a host app.


The smaller file is an installer app. In turn it accesses a server for the full download. What’s strange here: the full installer downloads a file about a gig less in size than the in app install. If you are using the full installer, I suggest uninstalling the existing app via its uninstall app located in the App’s folder, then run the full installer. Last time I just ran the full update without the uninstall first. Upon restart app was showing oddities.

You nd Mike Rogers didn’t mention if you are using the CPU or GPU for processing. I ran a test on my Windows 10 machine using a 48 Mpx file (pretty large). For my RX5600 XT GPU it took 19 seconds to process and save the picture. I ran again using my Ryzen 2600X (6 core) CPU and it took 6 min 18 sec. Clearly Sharpen is optimized for GPU use. My setting was Out of Focus > Normal, Remove blur=47.

The CPU was only utilizing 50% according to task manager.

The mask painting bug has been reproduced by Topaz, a fix will happen at some point.

1 Like

Sharpen AI 3.1 does a worse job on removing motion blur than version 1.9 (the 1’st version I used) !
2.2.2 was better and 2.4.2 was the best.
Since 3.0.0 it’s been downhill, the CPU mode worked okay but the GPU output was horrible.
Now with version 3.1 the CPU and GPU output the same horrible quality, excessive fringing on high contrast edges and a shift of the image down & camera right with relative motion streaking of highlights.
I’ve tried to attach some examples of the progress/regression of the software, this forum wont let me.


Can you make jpg screen snips? They would be uploadable.

That would explain why my png wouldn’t upload. The error message was unhelpful.

Thanks for the explanation. I agree with you – it is “strange” and I wish Topaz could have explained it in the initial instructions for updating. I used the installer app and so far all seems to work well. It runs well on the M1 Mac Mini.

Weirdly, I cannot mask anything at all successfully in v3.1 :frowning: Mac OS 11.2.3, 2019 27in iMac

Auto detect misses quite badly and to make things worse, it also refuses to erase or add to the mask. Painting it on from blank results in this weirdly shrunken mask too (which also cannot be modified)

Any thoughts?

This is a user-user forum but I think the dev team check it fairly regularly too.

Another option for you is to use the little smiley/sad faces in the app to rate & explain your rating. But, of course, that won’t provide the same impact as seeing different results on the same image using diff product gens side x side…

1 Like

Sorry, I’ve been away, it’s in GPU Mode.

Yep. I never had problems with layer masks in Photoshop where I use Topaz apps as plug-ins.

I agree with you that the masking is terrible. Painting over an object goes ok but when I stop painting the mask shrinks. Also, edge aware does not work. I was testing the stand alone version.

1 Like

It’s a known issue, hopefully a fix in the next release. Meanwhile I’m back on v3.0.3

Hello - this updated does not fix the WIN-7 x64 problems as we were told it would.
how are you addressing the, 1st - kernel32.dll & the 2nd, a hddlapi.dll errors ??

The problems are worse under this update !

WIN-7 is a must still for us, regardless of how microsoft is putting it under the rug.
As photo professionals, we can not use our scanners under WIN-10, and there are no high-end scanners that run under WIN-10.

advise on this issue, thanks. dw


Same Kernel errors on Windows 7 during startup as when v3.1 was first released…?
Already put in a ticket on it, was told others having same issue and to roll back to version that did not do this.
So far this is the only Topaz module doing this, I hope you are working to fix it and don’t let Win7 fall over the side!

I too wrote them back when v3.1 was first released, I was sent a couple other installs to try; both did the same thing, same errors.
I was told to roll back to the older version that worked - now it’s getting scary. This is the ONLY Tapaz module that gives these errors, if the rest begin to follow…