Sharpen AI upgrade to Version 3.0.3 - still having problems

I couldn’t get any of the Sharpen AI v3 iterations to work on my laptop. In frustration I went back to the last v2 version.
Someone told me about V3.0.3, and I installed it hoping the problems I had had been corrected. Nope. I use Sharpen AI as an ad-on to Lightroom. I can start the process of sharpening an image but it hangs there for ever until I cancel it and get a Non Responding message. I have an ACER laptop with 8 Gb RAM, 64- bit operating system Windows 10 Home version 20H2, with an AI Processor Intel® UHD Graphics 620.

Can you help?

I am also having problems with the new update. It shuts itself off after loading before one can do anything. It is now useless, I am sorry I updated. I do not know where to find a older version to download.

I had a chat with one of the Topaz Labs technician and she made me change the AI Processor to CPU in File - Preferences for both DeNoise and Sharpen and it worked! I don’t have an issue with v3.0.3 anymore.
Try it, it might work for you too.

If not, you should be able to find your older version in your Download folder. The name of the file should start with TopazSharpenAI- You need to uninstall the current version before installing the older one.

Good luck.

Thank You, It Worked.

Nope I tried this and still the same!